[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Missing Shared Object File for ffmpeg

I have two stretch systems, named deb4 and deb9. Both were installed
via netinst, have the latest apt update; apt upgrade, and report:

$ uname -v
#1 SMP Debian 4.9.82-1+deb9u3 (2018-03-02)

Several attempts to install ffmpeg on deb9 have appeared to succeed,
but ffmpeg with various options consistently reports:

ffmpeg: error while loading shared libraries: libopenal.so.1: cannot
open shared object file: No such file or directory

On the other system, deb4, ffmpeg installed and ran immediately and was
successfully used to split a .mov file into two parts.

/etc/apt/sources.list is the same on deb4 and deb9. I have compared the
package versions on deb9 with those on deb4 and they are the same.
Before reinstalling ffmpeg on deb9 I ran:

# apt purge ffmpeg
# apt autoremove
# apt install ffmpeg

I've run ldconfig and repeated the above. STW, I've set
LD_LIBRARY_PATH=/usr/local/lib and repeated. Also tried:
# apt search openal
...and saw that it contains libopenal.so.1 but:
# apt install openal
E: Unable to locate package openal

What do I need to do to figure out what's wrong with deb9?

 - Dan

Reply to: