[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Problems with KDE in Debian Stretch

Hi, Felix.

On 10/03/18 19:11, Felix Miata wrote:

> Daniel Bareiro composed on 2018-03-10 13:42 (UTC-0500):
> ...
>> hardware: a Thinkpad T530.
>> About five days ago, after researching the Internet, I tried adding this
>> configuration in Xorg:
>> ---------------------------
>> viper@orion:~$ cat /usr/share/X11/xorg.conf.d/20-intel.conf
>> Section "Device"
>>    Identifier  "Intel Graphics"
>>    Driver      "intel"
>>    #Option      "AccelMethod"  "sna"
>>    Option      "TearFree"    "true"
>>    Option      "DRI"    "3"
>> EndSection
>> ---------------------------

> Have you ever tried the default driver? Search tells me T530 has HD Graphics
> 4000 on Ivy Bridge, roughly 5-6 years old, which ought to work with it if not be
> optimal. It's built into the Xorg server in Stretch. To use can take as little
> effort as not having xserver-xorg-video-intel installed, but in your case it
> will likely require eliminating or modifying 20-intel.conf.
> I have multiple Intel gfx machines, all older or newer than Ivy Bridge. All use
> the integrated modeset(0) driver with any server newer than 1.16.x.
> The Intel gfx driver hasn't had a formal release in going on 4 years, nothing
> but cgit milestones since 2.99.917.
> https://cgit.freedesktop.org/xorg/driver/xf86-video-intel/
> https://www.phoronix.com/forums/forum/linux-graphics-x-org-drivers/intel-linux/886898-ubuntu-debian-abandon-intel-x-org-driver-for-most-hardware-moves-to-modesetting-ddx

I think that before adding the file with the configuration that I
mentioned (/usr/share/X11/xorg.conf.d/20-intel.conf), I was using the
default driver. At least I don't have a /etc/X11/xorg.conf file.

In essence the configuration I suppose that it will have been the same
one that I kept previously with Jessie and with which it was not having
problems with Jessie.

Currently I have these packages installed:

i  xorg - X.Org X Window System
i A xorg-docs-core - Core documentation for the X.org X Window System
i A xorg-sgml-doctools - Common tools for building X.Org SGML documentation
i A xserver-xorg - X.Org X server
i A xserver-xorg-core - Xorg X server - core server
i A xserver-xorg-input-all - X.Org X server -- input driver metapackage
i A xserver-xorg-input-libinput - X.Org X server -- libinput input driver
i A xserver-xorg-input-wacom - X.Org X server -- Wacom input driver
i A xserver-xorg-legacy - setuid root Xorg server wrapper
i A xserver-xorg-video-all - X.Org X server -- output driver metapackage
i A xserver-xorg-video-amdgpu - X.Org X server -- AMDGPU display driver
i A xserver-xorg-video-ati - X.Org X server -- AMD/ATI display driver
i A xserver-xorg-video-fbdev - X.Org X server -- fbdev display driver
i A xserver-xorg-video-intel - X.Org X server -- Intel i8xx, i9xx
display driver
i A xserver-xorg-video-nouveau - X.Org X server -- Nouveau display driver
i A xserver-xorg-video-qxl - X.Org X server -- QXL display driver
i A xserver-xorg-video-radeon - X.Org X server -- AMD/ATI Radeon display
i A xserver-xorg-video-vesa - X.Org X server -- VESA display driver
i A xserver-xorg-video-vmware - X.Org X server -- VMware display driver

I guess these would be the same packages I was using with Jessie (if so,
I suppose I would also have installed xserver-xorg-video-intel), but
honestly, I don't have registered the ones I had installed then.

Regarding hardware, here is some more information provided by lspci:

viper@orion:~$ lspci -s 00:02.0 -vvv
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core
processor Graphics Controller (rev 09) (prog-if 00 [VGA controller])
        Subsystem: Lenovo 3rd Gen Core processor Graphics Controller
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop-
ParErr- Stepping- SERR- FastB2B- DisINTx+
        Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort-
<TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0
        Interrupt: pin A routed to IRQ 28
        Region 0: Memory at f0000000 (64-bit, non-prefetchable) [size=4M]
        Region 2: Memory at e0000000 (64-bit, prefetchable) [size=256M]
        Region 4: I/O ports at 5000 [size=64]
        [virtual] Expansion ROM at 000c0000 [disabled] [size=128K]
        Capabilities: <access denied>
        Kernel driver in use: i915
        Kernel modules: i915

Note: I'm curious about the "<access denied>" in Capabilities.

Meanwhile I am testing the workaround suggested by Bernd about changing
the composer.

Thanks for your interest.

Kind regards,

Attachment: signature.asc
Description: OpenPGP digital signature

Reply to: