[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Missing libGL.so.1 from ldconfig

On 2018-03-10 at 19:52, Curt Howland wrote:

> Ok. Having some difficulty getting GL to work.
> Stable, up to date. Running Wine32, the package libgl1-mesa-glx:i386
> is installed, but no matter what I do I keep getting
> # ldconfig -p | grep libGL.so.1
>         libGL.so.1 (libc6,x86-64) => /usr/lib/x86_64-linux-gnu/libGL.so.1
> On a different system, where I did nothing at all beyond install
> Wine32, the libraries are there just fine:
> # ldconfig -p | grep libGL.so.1
>         libGL.so.1 (libc6,x86-64) => /usr/lib/x86_64-linux-gnu/libGL.so.1
>         libGL.so.1 (libc6) => /usr/lib/i386-linux-gnu/libGL.so.1
> I've tried "ldconfig", I've tried putting "/usr/lib32" in
> /etc/ld.so.conf.d/local.conf
> I've even tried "dpkg-reconfigure libgl1-mesa-glx:i386" just to see if
> the install script needed to get kicked, nothing worked.
> Any ideas?

At a first guess: what's the contents of /etc/ld.so.conf?

On my system, it just loads the /etc/ld.so.conf.d/*.conf snippets; what
snippets do you have there, and what directories they point to? In
particular, do any of them point to /usr/lib/i386-linux-gnu/ ?

(Also, have you checked that directory to confirm that libGL.so.1 is
actually present there?)

   The Wanderer

The reasonable man adapts himself to the world; the unreasonable one
persists in trying to adapt the world to himself. Therefore all
progress depends on the unreasonable man.         -- George Bernard Shaw

Attachment: signature.asc
Description: OpenPGP digital signature

Reply to: