[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

DRI missing file


I have problem with DRI missing file. I find this solution:

I encountered an issue with the same symptoms (no /dev/dri so X won't start) which I believe is actually caused by a udev update. I had upgraded from udev-171 to udev-181 (and several other packages), and when I rebooted, X failed to start. I had made several other changes including upgrading xorg-server to 1.12 and xf86-video-intel to 2.18, so I wasn't sure who the culrpit was. I tried reverting everything, including dbus, mesa, libdrm, etc., but I wasn't able to resolve my issue. I also tried upgrading, going to kernel 3.3.0 from 3.1. I then tried upgrading udev from 181 to 182 and noticed the message about "CONFIG_DEVTMPFS" missing. I rebuilt my kernel (3.3.0-gentoo) to include both that and CONFIG_DEVTMPFS_MOUNT and now my issue has gone away. X works great (I am now running the latest ~amd64 versions of everything I mentioned). 

Do you have some manual to do this. I use this kernel version 4.9.22-custom.

Please i need halp soon as psoible

Reply to: