[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Synaptic problem - physical access to CD drive related

I have 3 machines with differing problems physically accessing the CD/DVD drive. To install Debian I routinely use a USB connected drive WITHOUT any problem by using the BIOS option to select a boot device.

The SOURCES.LIST(5) man page hints that I should be able us something like
    file:/media/richard/Debian 9.1.0 i386 1

Neither worked. Man page suggest the space characters to be the problem.

I did
root@stretch17oct2017:/home/richard# findmnt
TARGET                                SOURCE      FSTYPE  OPTIONS
/                                     /dev/sda9   ext4    rw,relatime,errors=rem
.> └─/media/richard/Debian 9.1.0 i386 1 /dev/sr1 iso9660 ro,nosuid,nodev,relati

root@stretch17oct2017:/home/richard# mount  /dev/sr1 /home/richard/Desktop/testcd
mount: /dev/sr1 is write-protected, mounting read-only

When I run Synaptic, it complains about a line in sources.list
   file:/home/richard/Desktop/testdvd stretch main contrib non-free

The error message is
E: Type 'file:/home/richard/Desktop/testdvd' is not known on line 2 in source list /etc/apt/sources.list
E: The list of sources could not be read.
Go to the repository dialog to correct the problem.
E: _cache->open() failed, please report.

What can I do?

Reply to: