[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: need a video function in wheezy

On 11/17/17 01:33, Gene Heskett wrote:
On Thursday 16 November 2017 23:33:43 David Christensen wrote:

On 11/16/17 18:21, Gene Heskett wrote:
I have a machine vision utility for use on a CNC machine, that uses

But the launching script, in xml, is looking for a specific lib:

   <requires lib="gtk+" version="2.24"/>

which if it ever did exist in wheezy, was since removed.

This script is of course editable, so are the functions that were in
this lib, now available in a different package? If so, likely
suspects please?

What about libgtk-3-0?


I have that, but this is wheezy, and the application has not yet been
built on stretch. Something about being incompatible with rtai kernels
newer than:

gene@GO704:~/linuxcnc/configs/GO704fast$ uname -v
#1 SMP PREEMPT Debian 3.4.55-4linuxcnc

as the app needs decent realtime performance.  It is running heavy

It also changes the error message by changing "gtk+" and "2.24" to
"gtk" and "3.0.0" which I have in /usr/lib/i386-linux-gnu. But the
video still doesn't work. It does work when using qv4l2 to view the
camera output. But an lsof while its running says it is not using that
particular library.

This library overlays aiming target patterns like circles and crosshairs
on the video I believe.

And a couple months back, it worked most of the time. It would fail if
the parent apps window for its display was drag expanded to more than
480 pixels high.

So how do I change this line in the xml launcher, so it works with the
newer version that I do have.

   <requires lib="gtk+" version="2.24"/>

This is what I have:
gene@GO704:~/linuxcnc/configs$ ls -laR /usr/lib/i386-linux-gnu|grep libgtk
drwxr-xr-x   2 root root     4096 Oct  5  2015 libgtk2.0-0
drwxr-xr-x   2 root root     4096 Jun  5  2016 libgtk-3-0
lrwxrwxrwx   1 root root       19 Oct 28 12:12 libgtk-3.so -> libgtk-3.so.0.400.2
lrwxrwxrwx   1 root root       19 Oct 28 12:12 libgtk-3.so.0 -> libgtk-3.so.0.400.2
-rw-r--r--   1 root root  4990504 Apr 17  2016 libgtk-3.so.0.400.2
lrwxrwxrwx   1 root root       29 Oct 28 12:12 libgtksourceview-3.0.so.0 -> libgtksourceview-3.0.so.0.0.0
-rw-r--r--   1 root root   492616 May 15  2012 libgtksourceview-3.0.so.0.0.0
-rw-r--r--   1 root root  7216108 Aug  6  2012 libgtk-x11-2.0.a
lrwxrwxrwx   1 root root       27 Oct 28 12:12 libgtk-x11-2.0.so -> libgtk-x11-2.0.so.0.2400.10
lrwxrwxrwx   1 root root       27 Oct 28 12:12 libgtk-x11-2.0.so.0 -> libgtk-x11-2.0.so.0.2400.10
-rw-r--r--   1 root root  4656508 Aug  6  2012 libgtk-x11-2.0.so.0.2400.10

Note that the first 2 subdirs are empty, however there are libgtk-this
and that packages that are not installed. Perhaps one of them is the
"magic twanger" needed?

Thanks David

Re: need a video function in wheezy

D'oh! When replying to a post, I'm looking at the body of a message and tend to forget requirements stated solely in the subject line.

Have you searched through the releases of Wheezy to see if any have the specific version of the library you need? If found, air-wall the machine, put in a new system drive, install that release, install the software, get it working, and never update.

Does anybody know if any hypervisors support real-time virtual machines?

Otherwise, it's a matter of finding the software maintainer and convincing them to bring the software up to date.


Reply to: