[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Debian Live USB fails; bricks the USB stick

Kent West wrote:

> I walked away then and came back in a few minutes to find it had finished,
> but didn't pay attention to any other messages, and then tried booting it
> on another year-old Dell PC. It gave me the grub menu, but then when I
> tried to boot Debian Live, I got an error about an invalid magic number and
> a need to load a kernel first.

I stumbled over something last night with the netinst installer and a
Dell Latitude E7250 (which still had Windows on it).  I don't know if
it's related to your problem, but in case it might be relevant, I
thought I'd mention it.

I was able to boot the installer from a thumbdrive, and it would get
through a couple screens (e.g., locale), but then it would get no
further, saying it couldn't find the "CDROM" (i.e., the thumb drive).  I
eventually came across this text in the Installation Guide[1]:

  On some UEFI systems, the firmware will reduce “boot” time by not
  initialising the keyboard controller or USB hardware

I booted the BIOS setup and changed the system from fast boot to
"thorough" boot.  That fixed my problem.


[1] https://www.debian.org/releases/stable/amd64/ch03s06.html.en#disable-fast-boot

Reply to: