[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Ethernet card locking up when acting as virtual bridge

On 09/11/2017 19:52, Michael Stone wrote:
I'd wonder if it's reached the point tha that the hardware is failing.
I was a bit premature in thinking it was fixed!  Tried 3 different 3Com cards now plus a Linksys with a Via chipset but got identical behavour on all.

Back to the original config: did you know you could add the built-in adapter to the bridge, give your IP address to the bridge rather than directly to the built-in interface, and use the VMs the same way you are now without a second NIC?

Yes but as I was experiementing I wanted to keep it separate so if I screwed up I could at least still SSH into the host.

The weird thing is I have 3 VMs, all started with the same commands just the made up MAC address and virtual bridge port numbers differing. One of them has never given a problem it always works, the other two seem to alternate, one "goes offline" the other comes online, then vice versa, yet if I use VNC to bring up the console for the VM it is still running ok and I cant see any log messages on it indicating that the network has gone down.

The arping command  is indicating that when a VM goes offline it is not responding to ARP requests over the network yet it does from another VM and can be connected to perfectly from another VM

I then had a brainwave, I had a similar issue with a Cisco wifi access point where some wifi clients could connect ok, others would connect but then there was no traffic flowing.

That turned out to be the Cisco switch on the other end which is an ESW500 series Small Business Switch (i.e web gui only no IOS CLI). On there there is a 'Smartports Wizard' which allows you to set a 'role' for each port and unless it is set to 'Access Point' I got the strange behaviour.

 As the virtual bridge and wifi access point are pretty much the same thing in principle I tried changing the port role to 'Access Point' as well and it seems to have solved the issue. Ive no idea what that is changing in the switch config, and when I asked on the Cisco forum I couldnt get an answer but it seems to be the cause of the trouble.

Reply to: