[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Debian Live USB fails; bricks the USB stick

On Wed, Nov 8, 2017 at 2:41 AM, Thomas Schmitt <scdbackup@gmx.net> wrote:

Felix Miata wrote:

> Also, why are this/these stick(s) getting flip-flopped between sdd and sdc?

That's because Kent plugged them in at the same time, i guess.
sdc is the clearly ill one, sdd is the one which is at least readable.



Kent West wrote:
> > > dd: failed to open '/dev/sdd': Read-only file system

i wrote:
> > Why does dd talk of filesystems ?

Henrique de Moraes Holschuh wrote:
> Because the only error number usable for "this thing is read-only" in
> POSIX is EROFS, so that's what a read-only block device reports.
> ...
> Anyway, if this is a pendrive or some other flash-based media, it most
> often means it is in the fail-safe last-resort mode (switched to
> read-only access so that you can try to salvage some data off it).

Valid theory. One can read this in the web about SanDisk devices.

But i am reluctant to declare two out of two USB sticks ill.
For now i still deem it possible that something like udev decided to
block access because of the data it saw on the device.

That's kind of what I thought. One stick? Sure, likely. Two sticks? Considerably less likely. But possible.

The decisive experiments would be to try writing to the sdd stick on
some other operating system with very different software between kernel
and userland. (Best would be an old GNU/Linux without any systemd/udev.)

Good idea. Pretty obvious idea; I don't know what I hadn't already tried that.

I just plugged the "can't see it at all anymore" stick into an iMac. Does not show up on Desktop; does not show up in Disk Utility; "dmesg" doesn't seem to mention it, unless it's in this single line - "USBMSC Identifier (non-unique): AA4011200010511 0x5dc 0xa790 0x1100, 2".

The somewhat-still-working stick, when inserted into the iMac, brings up a pop-up window that says "The disk you inserted was not readable by this computer. Ignore/Eject". Disk Utility sees it as an "Unknown" disk2s2 426KB external drive. But it lets me try to Erase it, although that results in an error saying "Couldn't modify partition map." I tried all four formatting options (Mac OS Extended Journaled, Mac OS Extended Case-sensitive Journaled, ExFAT, MS-DOS (FAT)). I tried tinkering with the Security Options.

If it had been one stick, I would just assume the stick had gone bad. But two sticks, at the same time, happening by the same process, sure seems suspicious.

Just to round out the OSes, I'll go see if I can find a Windows machine.

Although i really do not believe in the theory that the ISO can kill
the USB stick, i leave the decision to Kent whether he wants to risk
a third stick (preferrably a young one) for experiments.

If I had a third one handy, I probably would. But without running to Wal-Mart, or waiting a day or three for an on-line order, I'm currently out of sticks. I'm sure I can come up with one in a day or few, and scrunching my visage up in concern that I'm going to waste another stick I'm sure I'll experiment with it, but at the moment, these two are all I have.

Thanks for everyone's input!

Have a nice day :)


Kent West                    <")))><
Westing Peacefully - http://kentwest.blogspot.com

Reply to: