[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Debian Live USB fails; bricks the USB stick

On Tue, Nov 7, 2017 at 12:41 PM, Patrick Bartek <nemommxiv@gmail.com> wrote:
On Tue, 7 Nov 2017 10:58:58 -0600 Kent West <westk@acu.edu> wrote:

> I wanted to create a Live Debian USB stick (using an existing Debian
> system). I remember doing such a few years ago with "unetbootin", but
> when I looked for "unetbootin" via aptitude search, I couldn't find
> it, so I did a quick "unetbootin debian" search, and found a Debian
> bug report from 2015
> (https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=775689) that led
> me to believe I should not use unetbootin, but to use the newer
> method of simply dd'ing the .ISO to the USB drive.
> So I went to
> https://cdimage.debian.org/debian-cd/current-live/amd64/iso-hybrid/
> and downloaded the AMD64 Cinnamon version of 9.2.0, and then inserted
> my USB stick, found it on /dev/sdc, and ran the command:
> sudo if=debian-live-9.2.0-amd64-cinnamon.iso

I'd give the complete path to the downloaded ISO.  dd's pretty stupid.

> <https://cdimage.debian.org/debian-cd/current-live/amd64/iso-hybrid/debian-live-9.2.0-amd64-cinnamon.iso>

Remove this.

That's just an artifact of my copy/paste into GMail; the actual command did not include the web address.

>  of=/dev/sdc
> I walked away then and came back in a few minutes to find it had
> finished, but didn't pay attention to any other messages, and then
> tried booting it on another year-old Dell PC. It gave me the grub
> menu, but then when I tried to boot Debian Live, I got an error about
> an invalid magic number and a need to load a kernel first.
> Not finding any documentation that might help, I checked the md5sum
> on the downloaded file (it was correct), and tried the dd again. Same
> result.
> I tinkered a bit, and then the next time I tried a dd, I noticed that
> it was giving me an input/output error for /dev/sdc. Still, it seemed
> to finish properly, but the boot attempt gave the same failed result.
> So I decided to try a different download; I tried the Mate flavor.
> Same result.
> So I decided to try a different USB stick. Same result.
> And now, both my sticks are complaining about being mounted
> read-only, and I can't seem to fix that.
> I tried "hdparm -r0 /dev/sdc", and that reports that it's set the
> read-only flag to off, but the stick still is read-only.
> So it appears that dd'ing a Debian .iso to a USB stick, at least
> using my hardware, bricks the USB stick.
> I'm assuming my attempt has cost me two USB sticks, and has just left
> a bad experience with Debian under my belt, and there's nothing I can
> do about it. (I don't even know where a bug report might go.) But I
> thought I'd put this info on the User's list, just for the record,
> and perhaps at the chance that someone might have a solution.

An install CD/DVD ISO is usually read-only and gets "designated" that
way when dd'ed to a USB stick.  This is normal.  If you
repartition/reformat/etc  the stick, then you can "correct" that and
make it writeable, again, but the ISO file is gone, of course.


That's good to know. Thanks! 

Kent West                    <")))><
Westing Peacefully - http://kentwest.blogspot.com

Reply to: