[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: lp printing doesn't work (Solved ... sort of)

On 08/30/2017 06:46 AM, Curt wrote:
On 2017-08-30, Brian <ad44@cityscape.co.uk> wrote:

Vary confused.

That makes two of us.

Try setting a per-user default queue, which overrides the system-level
setting in /etc/cups/lpoptions. The per-user default is stored in
~/.cups/lpoptions with 'lpoptions -d'. There is also a PRINTER variable
(see lp(1)) which can be used instead. It overrides ~/.cups/lpoptions.

There's also LPDEST? I was going to say check your PRINTER and LPDEST
environment variables, as they take precedence over whatever is set (if
anything) by the lpoptions and lpadmin commands. However I was unsure
whether the error message corresponded.

lpstat -p gives all spooler destinations.

Well I guess I have solved this. Not sure why. I originally pasted the Default <printer> -o <options> into lpoptions from another lpoptions file. When I. instead, ran lpoptions -d <printer> and then pasted in the -o options, things started to work.

Haven't a clue as to why this made a difference. The file ended up looking the same.

Thanks for all of the help.

Gary R.

Reply to: