[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Darn 'beep' stoped working after installing Stretch in place of Jessie

On Tue, 01 Aug 2017, Dejan Jocic wrote:
> On 01-08-17, RavenLX wrote:
> > Having it work out-of-the-box would be nice. After a fresh install, I have a
> > bash script I run that installs all the apps I use and configures them.
> > Sometimes though, there are things that a user needs to answer. Thus, if I
> > want to have the script running and go do something else, I want to "beep"
> > when it's going to need attention by the user. I noticed this does not work
> > in Stretch so I ended up removing the part to install the "beep" package and
> > use beep to alert the user. I have tried escape codes via echo -e as well,
> > and no beep there either.
> Does printf "\a" works for you? Though, echo -e "\a" works here too.

If it doesn't, you likely must fiddle with "digital beep" controls in
the sound subsystem.  Check alsa (alsactl, amixer...) and pulse audio
(pauvcontrol).  And try it from an xterm or the Linux text-mode console
just to make sure the beep ioctl is actually being issued...

  Henrique Holschuh

Reply to: