[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Darn 'beep' stoped working after installing Stretch in place of Jessie

On 07/31/2017 05:21 PM, Juan R. de Silva wrote:
Hi folks,

I installed (fresh install instead of an upgrade) Debian Stretch on my laptop.
The installation is full success without any problem except a little one -
'beep' does not produce a sound neither from CLI nor from a bash scripts. I had
Jessie installed on the same laptop before and it worked just fine.

I checked everything I possibly could: pcspkr module loaded, alsa does not have
any muted channels, tried to use it as a user and as a root. No clue why it does
not work any longer in Strech.

Any suggestions?


I've noticed that as well. I'm very sorry I don't know if my experiences below is a solution for you (or at all) but maybe my saying something might mean others won't think as I first did that it was my hardware or something. Sound does work fine in my system. I even tried adjusting the sound levels and setting notifications for system beep. Nothing seemed to work.

Having it work out-of-the-box would be nice. After a fresh install, I have a bash script I run that installs all the apps I use and configures them. Sometimes though, there are things that a user needs to answer. Thus, if I want to have the script running and go do something else, I want to "beep" when it's going to need attention by the user. I noticed this does not work in Stretch so I ended up removing the part to install the "beep" package and use beep to alert the user. I have tried escape codes via echo -e as well, and no beep there either.

As for more information, I've tried this in a regular non-GUI shell (before installing a desktop environment) and also while in Konsole (KDE's terminal program). It did not work.

Now, if you install beep *after* you have installed your desktop environment, then it *does* work when you type "beep" at the Konsole prompt and in bash scripts.

I don't know why this is other than maybe you have to have your sound system pre-installed.

I don't know if this information would help you. I am beginning to wonder also if the update to 9.1 fixed things. I had the experience with 9.0.

Another thing to try is to update your system to 9.1 and see if that fixes it.

Reply to: