[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Unable to install custom package using defined dependency version



Hi,
I have a custom package named 'app-configs' with the following versions uploaded to Artifactory: 1.0.5~aaa and 1.0.6~bbb.

In another custom package, named 'my-app', I have the following in the control file

Depends: app-configs (= 1.0.5~aaa)

When I do 'apt-get install my-app', I'm seeing the following message:

"my-app : Depends: app-configs (= 1.0-5~aaa) but 1.0-6~bbbb is to be installed."

I just want to pin 'my-app' to use a specific version of 'app-configs'.

It seems that my qualifier of '=' isn't working as I expect. What am I doing wrong?

Thanks,

Sijis

Reply to: