[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: /tmp/.X0-lock

On Fri, May 05, 2017 at 06:06:30PM -0500, Charles Kroeger wrote:
> I can still
> use the sysvinit boot option that presents a graphical login and after that
> starts the X server. (I then have to run 'service network restart' to connect
> to the Internet and there is complaining about that being deprecated but good
> thing something works.

On Fri, May 05, 2017 at 09:04:02PM -0500, Charles Kroeger wrote:
> UID        PID  PPID  C STIME TTY          TIME CMD
> root      2994  2812  0 17:36 tty7     00:01:23 /usr/lib/xorg/Xorg :0 -seat
> seat0 -auth /var/run/lightdm/root/:0 -nolist
> that would be the one I'm using. I will try that command after stopping the
> X-server
> after stopping the X-server I ran: ps --fC Xorg
> on running startx (as user) the X server failed to start with these error
> messages:
> (EE) could not create lock file in /tmp/.tX0-lock

I'm assuming you are on stretch.

So, when you allow lightdm to run at boot, everything is fine, but if you
run "startx" as a non-root user from a text console, you get the error.

lightdm is running the X server as root (verified by your ps output),
and this is presumably creating the /tmp/.X0-lock (and/or .tX0-lock)
file(s) as root.

Then, when you try to run startx as a non-root user, it tries to create
the same file(s), but they already exist under a different owner (root),
and so it fails.  (And this would have worked under jessie, because the
X server ran setuid root in jessie.  Not so in stretch.)

The obvious temporary fix would be to remove those files (as root, after
verifying that the X server is indeed terminated).  I do not know how
a permanent fix would be achieved.  My first guess would be that either
lightdm or Xorg should be removing those files from /tmp upon termination,
but I don't know which one.

Reply to: