[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

attempt to read or write outside of disk 'hd0'

I've just done the first upgrades for months on a netbook and a USB
hard drive, both containing sid installations. Yes, I know that's
risky, but the longer you leave it, the riskier it gets...

The netbook was fine. The hard drive installation completed an apt-get
update and apt-get upgrade while booted on a two-year-old laptop. I
thought I'd reboot before the dist-upgrade, as I usually do this, and
lo and behold, I'm dropped to a grub rescue> prompt after the message
in the subject line...

I can list the (hd0,1)/boot/ directory, but insmod normal gives the
illegal access message again.

The Net mostly reckons this is due to using too large a drive on an old
BIOS, but since this very drive has booted on this very computer many
dozens of times, without change in the partition structure, that is not
the case here.

I plugged it into the netbook, where it has also worked many times,
with the same result. I booted the netbook itself, chrooted, did an
update-grub followed by a grub-install to the *correct* drive, no
errors found, no change in boot behaviour. As far as I can tell from
fdisk, the partition table looks right, or at least not wildly
incorrect as it would need to be to cause this.

I'm assuming this is not a kernel issue, as grub is failing to read its
own modules from partition 1 correctly, and has not come close to
displaying its kernel menu. Am I right? There is a new kernel, 4.7, and
that and later kernels certainly have issues on my main workstation.
It's an i386 installation, though I can't see that being relevant,
apt-get really shouldn't have put in any 64-bit-only stuff.

This is not a particularly valuable installation, it's no big deal to
reinstall, but that seems a very Windows thing to do. I'd like to fix
it, if anyone has any ideas.


Reply to: