[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

With Jessie 8.6, gdm3 and XDMCP, the GDM face browser is built but not displayed


We used during 2 years Gnome and gdm3 on a server with Debian Wheezy to let users open sessions from their Windows PC via Cygwin and xlaunch (xdmcp). It worked well till the upgrade to Jessie 8.5, for these Windows PC, as for the system console. The upgrade to Jessie 8.6 didn't solve the problem.

I have already tried to describe these problems the 09th of september ("gdm3 doesn't work any more after the upgrade from Wheezy to Jessie 8.5") :


As users were satisfied by the environment provided with gnome, when the server ran on Wheezy, I am still trying to launch gdm3.

The story is the same for the console (when the system restarts) and for the Windows PC (at each launching of xlaunch): I get during a split second a gray background screen, probably corresponding to the GDM face browser, followed during a new split second by a nice blue screen (debian 8 on the bottom-left corner, date and time on the middle, and a few icons on the upper left which are able to display information about the connection to the network), followed by a dark screen, till the first mouse or keyboard event, that activates definitely the blue screen. For the console the dark screen is very ephemeral and appears only once before the blue screen is displayed.

I have tried to follow what happens really and read carefully the /var/log files. It is clear that the GDM face browser with the list of all users is being built, but I have not understood why it is not displayed : warning and errors traced in these files should be more understandable for a person more expert than me in Gnome and gdm3. I have prepared a file with extracts from /var/log/system and /var/log/debug, compressed with bzip2 ...

I have read the warning about the upgrading from wheezie to jessie:
5.10. The GNOME desktop requires basic 3D graphics
The GNOME 3.14 desktop in Jessie no longer has fallback support for machines without basic 3D graphics. To run properly, it needs either a recent enough PC (any PC built in the last 10 years should have the required SSE2 support) or, for architectures other than i386 and amd64, a 3D-accelerated graphics adapter with EGL drivers.

It could mean that was I am trying to do is no more possible. But during the 3 first days just after the upgrading I had a degraded but nearly working situation with Windows PC: a few minutes to get the GDM face bowser, again a few minutes to get the session, which was then normal but impossible to close, and sometimes nothing. My attempts to improve the situation lead to a much clearer one: what I get now is always this nice blue screen, maybe built by gnome-screensaver (I am not sure at all). That was not exactly my aim... But it lets me think or hope that I am not in the case reported in the warning 5.10.

Today I don't ever know whether the problem I try to solve may be solved or not, and if it is due to an error of installation (lacking packages to install or packages to uninstall), or an error of configuration or, possibly, a bug of Jessie.

It would be nice if someone could answer that it works on his system : Jessie, gdm3 with xdmcp enabled and Windows PC emulating a X11 server with xlaunch (through Cygwin or another free software) to open sessions.

Many thanks in advance !

Best regards,


Attachment: extract_from_log.txt.bz2
Description: application/bzip

Reply to: