[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: File corrupt during Jessie installation - I have ot do something tonight, even use another distro. :-((



On 03/15/2016 11:59 AM, Lisi Reisz wrote:
My husband's computer died today.

First:

1.  Back up everything on all of the drives in the old computer.

2.  Take an image of the system drive in the old computer.

3.  Copy the above to another device and put the copy off-site.


What is the make and model of the computer?


What failed?


What do you need to do tonight? E.g. what software do you need? What version? Do you have data files created with a particular version that you need to open?


We rushed out and got another, cheap,
temporary one while his main one is being repaired.  I said that I could get
it up and running quickly.  Famous last words.

What is the make and model of the new computer?


I downloaded the most recent Jessie Net-install + firmware, didn't checksum it
because of the enormous problems I have getting the checksums (could we not
please, please just have a hyperlink?  I am not the only partially sighted
person in the world). Yes, risk.  But this is temporary, and no-one has been
yowling about corrupt files on the Debian website.

What image file did you download (please provide URL)?


Please verify the checksum of the file you downloaded.


I started the installation, and just after partitioning and the beginning of
files downloading got the following message:

Warning:  file:///cdrom/pool/main/g/gnupg/gnupg_1.4.18-7_amd64.deb was corrupt

Did you put the image file onto an optical disc or a USB flash drive? What make and model?


Please verify the checksum of the burned media.


So I aborted the installation and went back to my 8.02 disk which I have used
before.

It did exactly the same.  Got past partitioning (rather too fast???) and
started to install the software, then stopped with the same warning.

If you put the image on an optical disc, perhaps your optical drive is having problems (?).


I then tried 8.0.0.  Double checked the md5sum.

Good.


The firmware was too old.

Firmware for what device? Is the device required for what you need to do tonight?


So I broke open a new USB external optical drive, used the 8.0.2 and EFI
(which I had been avoiding) and tried again.  I hit the same problem at the
same point.  So this time I said "continue".  File after file was said to be
corrupt, but it appeared to be complaining that the files it was
*downloading* were corrupt.

One failure can cause a domino effect, even if the later stuff is otherwise okay.


Help!!  Am I reduced to using Ubuntu (<ouch>), or has anyone got any
constructive ideas?

Your idea, below, is valid.


Another idea is to pull the HDD(s)/SSD(s) in the broken computer and put them into the new computer.


As I wrote that I thought of DVD1.  I have never used it.  Perhaps I should??

Transient errors with FOSS project infrastructure servers are all too common. A corollary to Murphy's Law, the likelihood of a failure is directly proportional to the urgency of the need. ;-)


If you want to use netinst ISO's, you need a local package caching server with at least one valid package for all needed packages. I've used approx in the past, and it seemed to work. I hope it rejects/ isolates downloaded packages with bad checksums and/or signatures, but I have not confirmed this.


Downloading installer images and/or supplemental images to obtain all the packages you need is another way to protect against mirror server failures, and the only way I know of to install onto air-walled machines (burn to optical disc, as USB keys can be rooted). If you select a mirror during installation and the mirror is having issues, you can exit, pull the Ethernet cable, start over, select no mirror, and the installer will be forced to only use the packages on the installation and/or supplemental media.


I don't know if you need software that is only available on Jessie. I tried Jessie (8.2) a while back, and found it had issues. I currently run Wheezy with Xfce, and install from this image:


http://cdimage.debian.org/cdimage/archive/7.9.0/amd64/iso-cd/debian-7.9.0-amd64-xfce-CD-1.iso

Or, to conserve bandwidth:


http://cdimage.debian.org/cdimage/archive/7.9.0/amd64/jigdo-cd/debian-7.9.0-amd64-xfce-CD-1.jigdo


On 03/15/2016 12:06 PM, Lisi Reisz wrote:
> I tried another two and the second one the error message changed to
> "Couldn't download package".
>
> Is there a problem on the Debian site?  Or with whatever mirror it is
> helping itself to??

It is possible that the Debian mirrors are having issues, and/or the caching servers between you and the Debian mirrors. I don't know how to check.


On 03/15/2016 12:37 PM, Andrew M.A. Cater wrote:
> I'm not sure that there's a problem with all the Debian mirrors:
> retry the downloads - instead of usingftp.uk.debian.org  change it,
> perhaps toftp.de.debian.org  to check.

Good idea.


On 03/15/2016 01:22 PM, Lisi Reisz wrote:
> In the meantime I had downloaded the CD1, burnt it and tried with
> that - and had the same problem,

Further clues that something is wrong with the Debian servers and/or the caching servers between you and the Debian servers.


> and still trying to do a net install,
> although on every occasion I had told it to re-partition and format.

Once you partition a disk correctly, you shouldn't need to partition it again. That said, partitioning (correctly) won't hurt.


Even if I use existing partitions, I usually erase dm-crypt containers and format the file system.


> So I am trying to use Gparted on Knoppix to wipe the disk thoroughly
> and I'll try in order (with a good Gparted wipe in between) Net
> install 8.02, CD1 8.03, net install 8.0.0 for a minimum install.

If you're using MBR partition tables, you only need to wipe the first megabyte of the system drive. If you're using GPT, I believe you should also wipe the last megabyte. (The Wheezy installer seems to use MBR; I haven't experimented with switching my motherboard to UEFI and seeing if I can get GPT with Wheezy and/or Jessie.)


> Then, if I am still remotely, vaguely sane, I'll report back.

I find that taking good notes helps preserve my sanity when I'm under pressure. Capturing console sessions with cut/paste or 'script' is ideal, as it eliminates typographic errors. And, good notes become even more valuable latter.


On 03/15/2016 01:50 PM, doug wrote:
> While you have GParted running, why not make the partitions you want
> using that, and format them to ext4.

On Wheezy, I use:

1.  ext4 for /boot -- GRUB doesn't seem to understand btrfs.

2.  btrfs for everything else -- to detect bit rot.


David


Reply to: