[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

hplip and scanning not working on Jessie

I apologize for the length of this post, but I wanted to get all the info that I have available up front.

I recently upgraded to Jessie, using sysvint-core as my init and am having some printer problems.

I got the printer working. CUPS was apparently uninstalled during the upgrade. I had noticed that some CUPS files were being removed, but it looked like replacements for them were being installed. Anyway, I installed CUPS, found what driver it wanted (printer-driver-hpcups) and installed it, set the desktop to access the printer locally, and enabled remote printing. I can now print from the desktop and my wife can print from her laptop. Hooray!

Then I tried scanning. Libre Office, which under Wheezy allowed me to import a file from the scanner, no longer lists any devices when I try to do so. I noticed that libsane was installed, but sane was not. I installed sane. No difference.

I also noticed that the HP Device Manger no longer seems to work. I tried running it from the command line so that I could see the errors produced.

No matter which tool I tried to run, with the exception of hp-check, I get the following error:

# hp-setup
Traceback (most recent call last):
  File "/usr/bin/hp-setup", line 45, in <module>
    from base import device, utils, tui, models, module, services, os_utils
  File "/usr/share/hplip/base/device.py", line 42, in <module>
    import status
  File "/usr/share/hplip/base/status.py", line 59, in <module>
    import hpmudext
ImportError: libnetsnmp.so.15: cannot open shared object file: No such file or directory

According to http://hplipopensource.com/node/323 this happens when hpmudext.so is not in the correct place, but...

# python -V
Python 2.7.9

# locate hpmudext.so

# ls -l /usr/lib/ | grep python
lrwxrwxrwx 1 root root 32 May 12 2013 libpyglib-2.0-python2.7.so.0 -> libpyglib-2.0-python2.7.so.0.0.0 -rw-r--r-- 1 root root 15288 May 12 2013 libpyglib-2.0-python2.7.so.0.0.0
drwxr-xr-x 23 root root        20480 Jun 28  2013 python2.6
drwxr-xr-x 27 root root        20480 Nov 29 23:52 python2.7
drwxr-xr-x  3 root root         4096 Jun 28  2013 python3
drwxr-xr-x 31 root root         4096 Aug 16  2013 python3.2
drwxr-xr-x 32 root root        12288 Nov 30 00:00 python3.4

I am running Python 2.7.9 and the file IS in /usr/lib/python2.7/dist-packages/, so what next. I ran hp-check and it listed a number of unmet dependencies. I installed the required packages.

I still can't run any of the hp tools.

I re-ran hp-check and I get the following:

root@quixote:/home/marc# hp-check
Saving output in log file: /home/marc/hp-check.log

HP Linux Imaging and Printing System (ver. 3.14.6)
Dependency/Version Check Utility ver. 15.1

Copyright (c) 2001-13 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Note: hp-check can be run in three modes:
1. Compile-time check mode (-c or --compile): Use this mode before compiling the HPLIP supplied tarball (.tar.gz or .run) to determine if the proper dependencies are installed to successfully compile HPLIP. 2. Run-time check mode (-r or --run): Use this mode to determine if a distro supplied package (.deb, .rpm, etc) or an already built HPLIP supplied tarball has the proper dependencies installed to successfully run. 3. Both compile- and run-time check mode (-b or --both) (Default): This mode will check both of the above cases (both compile- and run-time dependencies).

Check types:
a. EXTERNALDEP - External Dependencies
b. GENERALDEP - General Dependencies (required both at compile and run time)
c. COMPILEDEP - Compile time Dependencies
d. [All are run-time checks]

Status Types:
    MISSING       - Missing Dependency or Permission or Plug-in
    INCOMPAT      - Incompatible dependency-version or Plugin-version

warning: debian-8.2 version is not supported. Using debian-7.5 versions dependencies to verify and install...


Kernel: 3.16.0-4-amd64 #1 SMP Debian 3.16.7-ckt11-1+deb8u6 (2015-11-09) GNU/Linux
 Host: quixote
Proc: 3.16.0-4-amd64 #1 SMP Debian 3.16.7-ckt11-1+deb8u6 (2015-11-09) GNU/Linux
 Distribution: debian 8.2
 Bitness: 64 bit


HPLIP-Version: HPLIP 3.14.6
HPLIP-Home: /usr/share/hplip
warning: HPLIP-Installation: Auto installation is not supported for debian distro 8.2 version

Current contents of '/etc/hp/hplip.conf' file:
# hplip.conf.  Generated from hplip.conf.in by configure.



# Following values are determined at configure time and cannot be changed.

Current contents of '/var/lib/hp/hplip.state' file:
Plugins are not installed. Could not access file: No such file or directory

Current contents of '~/.hplip/hplip.conf' file:
warning: Could not access file: No such file or directory
<Package-name> <Package-Desc> <Required/Optional> <Min-Version> <Installed-Version> <Status> <Comment>

|  External Dependencies |

policykit Admin-Policy-framework OPTIONAL - 0.105 OK - gs Ghostscript REQUIRED 7.05 9.06 OK - network Network-wget OPTIONAL - 1.16 OK - scanimage Shell-Scanning OPTIONAL 1.0 1.0.24 OK - avahi-utils avahi-utils OPTIONAL - 0.6.31 OK - dbus DBus REQUIRED - 1.8.20 OK - cups CUPS REQUIRED 1.1 1.7.5 OK 'CUPS Scheduler is running' xsane SANE-GUI OPTIONAL 0.9 0.998 OK -

|  General Dependencies |

error: reportlab Python-PDF-Lib OPTIONAL 2.0 3.1.8 MISSING 'reportlab needs to be installed' libcrypto OpenSSL-Crypto-Lib REQUIRED - 1.0.1 OK - pil Python-Image-Lib OPTIONAL - 1.1.7 OK - pyqt4-dbus PyQt4-DBUS REQUIRED 4.0 4.11.2 OK - libjpeg JPEG-Lib REQUIRED - - OK - libpthread POSIX-Threads-Lib REQUIRED - 2.19 OK - python-dbus Python-DBUS REQUIRED 0.80.0 1.2.0 OK - python-devel Python-SDK REQUIRED 2.2 2.7.9 OK - pyqt4 Python-Qt4 REQUIRED 4.0 4.11.2 OK - cups-devel CUPS-SDK REQUIRED - 1.7.5 OK - sane-devel SANE-SDK REQUIRED - 1.0.24 OK - libusb USB-Lib REQUIRED - 1.0 OK - sane Scan-Lib REQUIRED - 1.0.24 OK - cups-image CUPS-Image-Lib REQUIRED - 1.7.5 OK - libnetsnmp-devel SNMP-Networking-SDK REQUIRED 5.0.9 5.7.2 OK - python-xml Python-XML-Lib REQUIRED - 2.1.0 OK - python-notify Desktop-notifications OPTIONAL - - OK -

|  Compile Time Dependencies |

gcc gcc-Compiler REQUIRED - 4.9.2 OK - error: libtool Build-tools REQUIRED - - MISSING 'libtool needs to be installed' make GNU-Build-tools REQUIRED 3.0 4.0 OK -

|  Python Extentions |

cupsext CUPS-Extension REQUIRED - 3.14.6 OK - pcardext PhotoCard-Extension REQUIRED - 3.14.6 OK - error: NOT FOUND OR FAILED TO LOAD! Please reinstall HPLIP and check for the proper installation of hpmudext. error: hpmudext IO-Extension REQUIRED - 3.14.6 MISSING 'Not Found or Failed to load, Please reinstall HPLIP'

|  Scan Configuration |

hpaio HPLIP-SANE-Backend REQUIRED - 3.14.6 OK 'hpaio found in /etc/sane.d/dll.conf' scanext Scan-SANE-Extension REQUIRED - 3.14.6 OK -


error: Failed to get Scanners information.



Missing Required Dependencies
error: 'libtool' package is missing/incompatible

Missing Optional Dependencies
error: 'python-reportlab' package is missing/incompatible

Total Errors: 3
Total Warnings: 1

Run 'hp-doctor' command to prompt and fix the issues.


However, neither libtool, not python-reportlab is missing. Both are present and up-to-date for Jessie:

# aptitude show libtool
Package: libtool
State: installed

# aptitude show python-reportlab
Package: python-reportlab
State: installed

I tried to run hp-doctor, as hp-check suggested, but it gives me the same error about hpmudext.so.

Has anyone gotten this to work? Is this one of those instances where things are broken if you are not using systemd as init? Any help with this one? I don't scan a lot, but when I do it is because I need to. I use the HP Device manager to keep track of my ink supply, so that is kind of useful, too. I don't want to boot back into Wheezy just to scan a page, or check my ink levels.

Help.  Please.


Reply to: