[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

networking stopped after upgrade


For some years I've been using a debian system as my household
firewall/router. It's been sitting quietly working without any major
changes, but has suddenly stopped doing so following my last aptitude

Server eth0 is connected to my modem, and eth1 is connected to internal
devices, using iptables to nat them and dnsmasq to provide internal
naming. The first symptom after upgrade was that ifconfig showed that
eth1 had no packets passing through (none transmitted, received or
dropped), although eth0 and the external internet connection worked
fine. I tried rebooting - no change. I tried restarting
/etc/init.d/networking, which caused the symptoms to reverse: now eth1
works, internal traffic is fine, but absolutely nothing is happening on
eth0. It's now stuck like this and I haven't been able to get eth0 to
work again whatever I do.

ifconfig shows eth0 is configured correctly (ip address, netmask, etc)
and route shows the gateway is ok. dmesg doesn't show any obvious
problems. But there are no packages moving through eth0 at all. Since I
initially had this symptom with eth1, which now works, I guess hardware
problems are ruled out.

This is Debian 8.2, uname says 3.16.7-ckt11-1+deb8u5 (2015-10-09)

My /etc/networks/interface goes;
auto eth0
iface eth0 inet static

auto eth1
iface eth1 inet static

auto dsl-provider
iface dsl-provider inet ppp
pre-up /sbin/ifconfig eth0 up
provider dsl-provider

I'd made no changes at all to any configuration files before this setup
stopped working, and it had previously worked unchanged for a long time.

Any suggestions?


Reply to: