[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: apt-cacher-ng not expiring any more

Quoting Wolfgang Karall (lists+debian-user@karall-edv.at):
> On 15-09-11 11:06:58, David Wright wrote:
> > The wheezy-backports-sloppy version, 0.8.3-1~bpo7+1 (i386) worked
> > well, but only until Sept 5/6; on this occasion, the disppearing file
> > is debrep/dists/jessie/InRelease:
> > 
> > Bringing index files up to date...
> > Checking/Updating debrep/dists/jessie/InRelease... 404 Not Found
> Faced with the same problem, it seems removing the files that acng is
> complaining about from the local cache hierarchy stops it from trying to
> refresh it.
> This even worked with the backports (non-sloppy) version AFAICT.

Yes, I can confirm that, having just downgraded to it first.

Normally if there are problems I get an email:

Subject: Anacron job 'cron.daily' on alum

Error(s) occured while updating volatile index files for apt-cacher-ng.
Please visit http://alum:3142/acng-report.html to rerun the
expiration manually or check the error message(s) in the current log file(s).

Please check error messages in one of: /var/log/apt-cacher-ng/maint_1441883138.log.html
+/var/log/apt-cacher-ng/maint_1441802104.log.html /var/log/apt-cacher-ng/maint_1441715703.log.html
+/var/log/apt-cacher-ng/maint_1441623938.log.html /var/log/apt-cacher-ng/maint_1441537538.log.html

Normally I look at the log file because I'm not seated at the machine.
Having just made a repeated attempt at expiration with the browser at
I noticed that each error 404 line here is followed by a checkbox for
tagging it, and there's a delete button at the bottom. Tagging and
deleting these files fixed it: 3 GB will be saved.

Thanks. Note to self—use the browser interface.


Reply to: