[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

[SOLVED]Penguin Wireless N USB Adapter TPE-N150USBL

> > >    wlan0:avahi Link encap:Ethernet  HWaddr 00:c0:ca:72:68:d4
> > > 
> > > This also does not happen here.
> > 
> > Nor here.
> > 
> > > The OP's system has failed to get an
> > > IP address on the wlan0 interface and has been provided with one by
> > > avahi. Maybe the router and/or DHCP provision need exploring as a
> > > cause for this.

I believe this happened because I applied the command:

#ping router-ip-here

> > I don't know if is something that was assigned by the
> > host, or came from outside in which case it might indicate some sort
> > of radio communication has been made. (Hence my statement above.)

it was

> > Here's hoping the OP knows how to explore the router and/or DHCP provision.

I had set up the router a few months ago to reflect the two channels it delivers,
2.5 and 5.0 GHz respectively. Some of my applications that  use the router select
2.5 like a Kobo reader and the Sony PS3.  At the moment as WiFi goes only my Sony
Xperia phone connects to the 5.0 GHz channel. 

> The OP should be looking at syslog and/or the journalctl output. What
> avahi-daemon,avahi-autoipd and dhclient get up to should be in there.
> Posting the relevant lines here could help with a diagnosis and a
> solution.

Thanks for all the suggestions they don't hurt because when looking into one thing
something else comes up.

I really didn't have a faulty setup for the Penguin USB N type WiFi adapter as I
originally thought. I installed a driver from the Penguin site directly into the
/lib/firmware directory, the 9k_firmware_free-version/htc_9271.fw
I rebooted the computer but this didn't light up the USB adapter. I
tried all the available USB sockets and rebooted a few more times, stuff like
that, but the Penguin was dead.

I was fed up and went to bed shutting off the computer. During the night
there was a miraculous like occurrence. When booting up the next morning the
'dead' USB adapter now came on and started trying to connect to the router. Success
right? Wrong.  Later in the day I was reading about setting up these wireless
adapters and ran across this valuable command:

#iwlist wlan0 scan

by that command all was revealed. There were 19 cells in a 50 yard radius of
my adapter (with a hi-gain antenna) including my router but (I guess you've figured
it out by now) the adapter or the firmware doesn't 'see' the 5.0-GHz
channel. Completely invisible. Only the 2.5 GHz channel was listed in the wlan0

My /etc/network/interfaces file was set up like this:

# The wireless network interface

auto wlan0
iface wlan0 inet dhcp
      wpa-ssid  dlink-5.0GHz       <what's wrong with this ssid entry>
      wpa-key-mgmt WPA-PSK
      wpa-psk <the passphrase>

anyway by changing wpa-ssid  dlink-5.0GHz to 2.5GHz the adapter connected
promptly and  voilà.

After all that, joy did not manifold.  The down speed of the connection was no
good. I pay for 20 Mbits from the cable company but..that depends.  This is a
Debian story. I ran the Ookla speed test (speedtest.net) connected through the 
Intel Ethernet card in the PCIe slot wired to the back of the router and speedtest
did show 21Mbits. (middle of the morning on a business day) 5 minutes after that the
best the USB wireless N adapter could do was 7.0 Mbits down speed.

I'm looking into a PCIe wireless card duel channel adapter as an upgrade. Any good
experiences out there with a particular kind (for desktop computer with PCIe
slot) with free or non-free firmware I would like to hear your story.

Thanks for the discussion, it's been real


Reply to: