[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: xfce autostart command not running

On Thu, 7 May 2015 19:37:36 +0000 (UTC)
Liam O'Toole <liam.p.otoole@gmail.com> wrote:

> On 2015-05-07, <briand@aracnet.com> <briand@aracnet.com> wrote:
> > I've got the following in my Application Autostart tab
> >
> >   /usr/bin/setxkbmap -option ctrl:swapcaps
> >
> > but it never executes on start-up.
> >
> > I was hoping someone might be able to tell me how to go about
> > debugging the problem (and yes it is checked).
> Was a .desktop file created in ~/.config/autostart? If not, you can
> create your own, with the above command on the 'Exec=' line. There are
> lots of examples of .desktop files in /usr/share/applications. I think
> the Application Autostart GUI will only applications which are
> registered with the system in that way.

yes it did.

and it has started working. Honest and for true, I tried restarting xfce at least 3 times and it never worked.

then this evening i start it up and it worked just fine.


The setxkbmap command works for me on the command line, so i don't think permissions have anything to do with it, but here's the permissions anyway.

-rwxr-xr-x 1 root root 20336 Dec 25  2013 /usr/bin/setxkbmap

Very weird.  Maybe some sort of race condition at startup ? The one change I made was to enable the splash screen.  Maybe that has something to do with it ?

Thanks for the advice.


p.s. here's the swapctrl.desktop file.  some others may find it useful.

[Desktop Entry]
Comment=Swap CapsLock and Control
Exec=/usr/bin/setxkbmap -option ctrl:swapcaps

Reply to: