[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: tty2,tty3,... missing after fresh install

On 2015-05-01 17:42 +0200, Rodolfo Medina wrote:

>> After freshly installing Debian Jessie on my old laptop, with no graphical
>> environment yet, at prompt, only tty1 is present: if I press Alt-F2, Alt-F3
>> and so on, there's no prompt at all, no tty2, tty3, etc.  Is that normal?

Sven Joachim <svenjoac@gmx.de> writes:

> No, only a short delay before the login prompt appears is to be expected
> since systemd starts gettys by demand.  But that should hardly be
> noticeable.
> After you switched to tty2 and back to tty1, what does
> "systemctl status getty@tty2.service" print?

Here's the output:

● getty@tty2.service - Getty on tty2
   Loaded: loaded (/lib/systemd/system/getty@.service; enabled)
   Active: inactive (dead)
     Docs: man:agetty(8)

Brian <ad44@cityscape.co.uk> writes:

> No, it is not normal. As Sven Joachim says, activation of a tty is on
> demand and almost instantaneous. There were bugs relating to the
> behaviour you describe but they have been attended to. Please see the
> systemd bug record.
> What do you get for
>   dpkg -l dbus

Here's the output:

| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name           Version      Architecture Description
un  dbus           <none>       <none>       (no description available)

Francisco M Neto <fmneto@gmail.com> writes:

> Also, since you're using a laptop, have you tried Alt+Fn+F2?

It produces no effect.

Thanks all for your help.  The problem disappeared once I did `apt-get install
dbus'.  Before I put `solved' to the thread, what do you think was the cause?
I'm curious now.



Reply to: