[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: no bluetooth audio in jessie



Juha Heinanen wrote:

> A few days ago, I upgraded my laptop from wheezy to jessie.  After that
> I noticed that audio to my bluetooth speaker didn't work anymore.  I had
> been using alsa audio and had a bluetooth type entry in my .asoundrc for
> my speaker.
> 
> After a bit of digging it turned out that I had lost bluetooth audio,
> because bluez-alsa package does not exist in jessie.  If I understood
> correctly, the reason is that bluez version 5 does not support alsa
> anymore.
> 
> So I decided to try if my bluetooth speaker would work in jessies with
> pulseaudio.  Unfortunately that was not the case.  I got an error
> message:
> 
> Apr 12 12:22:02 lohi pulseaudio[6318]: org.bluez.Manager.GetProperties()
> failed: org.freedesktop.DBus.Error.UnknownMethod: Method "GetProperties"
> with signature "" on interface "org.bluez.Manager" doesn't exist
> 
> After a bit more digging, i found this thread that went way above my
> understanding:
> 
> https://github.com/ev3dev/ev3dev/issues/198
> 
> Long story short:  it would be nice if bluetooth audio would "just work"
> in jessie like it did in lenny and wheezy for years.
> 
> -- Juha

I had similar issue with upower where it lost the methods exposed to dbus.
The solution was to downgrade upower (install older version known to work).
Perhaps same is doable with the bluez package.
then mark the packages as "hold" so they don't get upgraded until solution
is provided.

regards



Reply to: