[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

apt stuck at "Reading database"

Dear all,

I had a power failure while I was away and when I came back the boot
failed, asking to run fsck manually, which I did.

*Many* errors where fixed and I could reboot to what it seems to be a
 normal session, except I cannot "dist-upgrade" or "upgrade" (I'm on
 sid, BTW):

Extracting templates from packages: 100%
Preconfiguring packages ...
(Reading database ...


At this point, it gets stuck. I can see two processes running:

# psf apt
 3988 pts/5    S+     0:23 apt-get dist-upgrade
 4411 pts/14   Ss+    0:00 /usr/bin/dpkg --status-fd 43 --unpack


dpkg.log does not help:

# cat /var/log/dpkg.log
2015-04-06 02:55:55 startup archives unpack
2015-04-06 03:01:22 startup archives unpack


I could not find anything wrong in other logs.

I've also tried "apt-get clean", to redownload the files, as well as
things like "apt-get -f install/dist-upgrade", "dpkg --configure -a",
moving /var/lib/apt/lists/ and /var/lib/dpkg/status. Nothing has
worked so far.

Any help would be greatly appreciated.

Best to all,


Reply to: