[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: useradd segmentation fault

On 11/07/2014 09:04 PM, Joris Bolsens wrote:
Ran into a bit of a strange error with useradd today,
whenever i run useradd I get a Segmentation fault.

I tried running fsck as i read it might be due to corrupt filesystem, but that didn't report any problems.
I reinstalled the passwd package, also to no avail.

I ran an strace and it seems it cannot allocate memory, which is strange as it is running as a vm on a machine with 32gb of ram,
and is provisioned to use whatever it needs and has 2gb reserved to it, not to mention that top shows only a fraction of that being in use.

I recently added ldap integration if that matters at all,
although none of the other VMs seem to be having issues with this
(granted the others are running CentOs, this being the ldap server)

Output of strace:

rt_sigaction(SIGPIPE, {SIG_DFL, [], SA_RESTORER, 0x7f259c6461e0}, NULL, 8) = 0

No idea, but why are you using realtime (rt_*) system calls?

Reply to: