[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: upgrade? broke exim4 [SOLVED]

On Wed, Jun 04, 2014 at 02:34:23PM +0200, Filip wrote:
> It tries to bind to the ipv6 adress of the local interface.
> Maybe ipv6 is disabled in your system. Do you see the ::1 address when
> you run 'ip addr' ?

Hi Filip,

    You hit the nail on the head. I didn't understand that in the message:
'socket bind() to port 25 for address ::1 failed' '::1' implied ipv6.

    Back in February I ran across a note on the Debian Wiki that turning
off ipv6 would speed up Iceweasel which is a real dog on dialup. With
that in mind I put this 'net/ipv6/conf/all/disable_ipv6 = 1' in
    Setting it to 0 and rerunning 'sysctl -p' got my fetchmail/exim4
connection working again.

    Now I guess I need to figure out if I can tell exim not to use ipv6
and if so how.

Many thanks to all who replied,
"Humor is an affirmation of dignity,
 a declaration of man's superiority to all that befalls him."
    - Romain Gary

Reply to: