[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: pinentry-gtk2 doesn't react to keyboard input

In addition, for the case I use pinentry-qt4,

$ ls -lrt /usr/bin/pin*
lrwxrwxrwx 1 root root     26 Jul 17  2013 /usr/bin/pinentry -> /etc/alternatives/pinentry
-rwxr-xr-x 1 root root 152904 Jan 24 12:29 /usr/bin/pinentry-qt4
lrwxrwxrwx 1 root root     30 Jun  3 10:57 /usr/bin/pinentry-x11 -> /etc/alternatives/pinentry-x11

lina@debian:~/.gnupg$ ls -lrt /etc/alternatives/pinentry
lrwxrwxrwx 1 root root 21 Jun  3 11:30 /etc/alternatives/pinentry -> /usr/bin/pinentry-qt4

in ~/.gnupg/gpg.conf I have commented out
# use-agent

and in

$ more gpg-agent.conf

###+++--- GPGConf ---+++###
pinentry-program /usr/bin/pinentry-qt4
default-cache-ttl 60
max-cache-ttl 600

it doesn't popup any input dialog window in this case except telling me a bad passphrase (no idea from where it reads such passphrase)


On Tue, Jun 3, 2014 at 11:20 AM, lina <lina.lastname@gmail.com> wrote:
but not sure it is relevant. since it doesn't happen before.

and I am striving to find out where they save/cache the passphrase? 

On Tue, Jun 3, 2014 at 11:07 AM, lina <lina.lastname@gmail.com> wrote:

I use icedove + enigmail for encryption with the pinentry-gtk2 as gpg-agent in the past.

It worked well until yesterday I added a new email account with new gpg key for it.

When the pop-up asked for passphrase, I just can't input anything inside.

Later I tried the pinentry-qt4 and pinentry-curses, there is even no popup except telling me bad passphrases.

Thanks ahead for any suggestions?

Best regards, lina

Reply to: