[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: failure to configure and compile a source code.

atar wrote:
> I've downloaded from bluez.org the source of the 5.7 package but

Any reason not to use the Debian packaged version already in Debian?

> when I ran ./configure on it, it emitted an error message at the
> bottom of all the messages saying:
> "checking for GLIB... no
> configure: error: GLib >= 2.28 is required"
> This, although I've the glib libraries installed.

Please verify that you have the libglib2.0-dev package installed.  It
contains the development libraries.

  dpkg -l libglib2.0-dev

> How can this problem be solved?

The glib development library is probably only the first missing
dependency that you hit.  I am sure there will be a long list of
others that will also need to be installed.

Try installing all of the build dependencies for the building the
Debian package.  This will probably be all that you need.

  apt-get build-dep bluez


Attachment: signature.asc
Description: Digital signature

Reply to: