[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: mdadm devices have the same name after install of Debian Wheezy

My mistake.

The raid device is showing up in /dev/disk/by-uuid/{the uuid}

The /etc/mdadm/mdadm.conf in initrd has two entries for /dev/md/0 which are supposed to be I think the two RAID 1 drives I think the wheezy installer might be broken at the moment because the first error is that /etc/mdadm/mdadm.conf isn't valid, it uses two uuids that don't exist in /dev/disk/by-uuid despite all the disks existing in /dev/disk/by-name, perhaps I should change the initrd to use names instead of uuids.

Hence, raid isn't working, and the lvm is on the RAID. If it's an md error it's raid, so thanks your answer points me in the right direction. lvm isn't going to work without raid.

On Tue, Apr 30, 2013 at 4:05 PM, emmanuel segura <emi2fast@gmail.com> wrote:
Hello John

I'm pretty sure the RAID and LVM are both MD devices but are using the same name

Ummm LVM is on dm and raid software is on md, try to check your lvm.conf into your initrd, because i thin the reason of your problem is, the vg was not  found


2013/4/30 John Tate <john@johntate.org>

I installed Debian Wheezy on a computer with two hard drives. Each drive has a software RAID partition (RAID1) but the first partition on the first drive is GPT and the second drive's first partition is /boot. On the software raid is a LVM with root, swap, and home all encrypted. I also tried encrypting the whole LVM before that and got the same error.

I'm getting an error right after grub loads the kernel with mdadm that I have two devices with the same name for /dev/md. Here is a screenshot of the full error:http://media.johntate.org/Pictures/Errors/2013-04-30%2013.15.03.jpg

I'm pretty sure the RAID and LVM are both MD devices but are using the same name. I'm pretty sure this is how I configured my other computer which isn't UEFI or GPT but had no trouble with it, suggesting a problem with the Debian installer perhaps. I might be wrong though, I can't see what else would be the problem. The installer for Wheezy shouldn't even let me make a mistake this big.

How can I fix this? It's strange.

Edit: I checked /etc/mdadm/mdadm.conf under the initrd using Busybox and there seems to be two entries for a md array called mises though I know I only created one.


esta es mi vida e me la vivo hasta que dios quiera


Reply to: