[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

mdadm devices have the same name after install of Debian Wheezy

I installed Debian Wheezy on a computer with two hard drives. Each drive has a software RAID partition (RAID1) but the first partition on the first drive is GPT and the second drive's first partition is /boot. On the software raid is a LVM with root, swap, and home all encrypted. I also tried encrypting the whole LVM before that and got the same error.

I'm getting an error right after grub loads the kernel with mdadm that I have two devices with the same name for /dev/md. Here is a screenshot of the full error:http://media.johntate.org/Pictures/Errors/2013-04-30%2013.15.03.jpg

I'm pretty sure the RAID and LVM are both MD devices but are using the same name. I'm pretty sure this is how I configured my other computer which isn't UEFI or GPT but had no trouble with it, suggesting a problem with the Debian installer perhaps. I might be wrong though, I can't see what else would be the problem. The installer for Wheezy shouldn't even let me make a mistake this big.

How can I fix this? It's strange.

Edit: I checked /etc/mdadm/mdadm.conf under the initrd using Busybox and there seems to be two entries for a md array called mises though I know I only created one.


Reply to: