[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Random crashes that won't allow rebooting easily

On 04/18/2013 07:41 AM, Bill Harris wrote:
I'm running an up-to-date Debian Squeeze 64-bit on a laptop.  It's
usually been stable, as I might expect from Debian Stable.  From time to
time, though, it freezes at seemingly random times.  I notice it mostly
when I'm typing and the keyboard stops responding, but I'm not sure it
always freezes while typing.  I can't do anything at that point, not
even select a virtual console.

I can't find an Alt-SysReq key on the laptop keyboard to kill it
semi-gracefully, so I kill it with the power button.

When I reboot, it usually boots partway and then freezes again.  It's
almost always just after it's said it's starting gdm3, checking battery
status, or starting ACPI.

Getting past that point is challenging.  I've tried disconnecting the
power and taking out the battery, but that rarely helps.  What usually
helps is to boot into Windows (W7, if it matters) and then shut down and
boot into Debian.  Sometimes it seems to help to pull the battery for a
bit, too.  Sometimes neither seem to help, and so I keep trying
combinations until it reboots.

Does that sound at all familiar?

Yes, though most likely not the same thing as yours, but this reminds me very much my problem with the "slow-keys" accessibility thing [1].

I believed my keyboard dies randomly and looked for hardware-related explanations. It took lot of effort to discover that its just gdm3. It wants my keyboard slow down a lot (so it seems dead) whenever I keep shift pressed for too long.

The short-term workaround is to switch "slow-keys" off each time it activates, but it is very time consuming (you have to keep shift pressed for very long time to deactivate this).

I still don't know how to get rid of this (tried few suggestions found on web with no result). According to gnome-settings-daemon maintaniners it's fixed in the version I have installed, so now in theory it is possible to switch it off somehow, but I don't know how.

[1] http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=682581

Reply to: