[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Channel Bonding Problem.

Hi list,
i'm trying to setup channel bonding on debian with modes active-backup.
For testing I'm using an old hp desktop (7 years old) with two nic

1) Integrate Broadcom Corporation NetXtreme BCM5751 GB [eth1]
2) Nic pci 3com 3c905C-TX/TX-M Fast Ethernet [eth0]

This is my (very simple) configuration:

iface bond0 inet static
address ip
netmask ...
gateway ...
slaves eth0 eth1
bond-miimon 100
bond-updelay 200
bond-downdelay 200
bond-mode 1

My test starts with eth0 as active slave. Disconnecting eth0 cable I must wait beetwen 5 and 30 secs to get slave change. This is translated as packet lost.
After this n seconds the bond0 starts to work with the second slave.
At this point I reconnect eth0 cable and eth1 remains the active slave as configured. Disconnecting eth1 cable, the slave change is performed immediately on eth0 without packet loss.
Performing the first operation the problem persists.

I've tried also with mode 6 without good result.

My first test was performed with a switch AT-8326GB (10 years old). I've changed this switch with a simple not-managed switch gb with 5 ports and the problem persists.

I've tried also to install and use for bonding two newer nic with chip rtl8139D without good result.

I've ridden on bonding.txt on kernel.org that some switch can cause different problems. I've tried to increase miimon, updelay and downdelay, but nothing.

I've tried to set on of two nics as primary with primary_reselect, nothing.

Sure this is not an hardware problem, but a misconfiguration.

Can some one point me in the right direction?

Thanks in advance.

See you, Alessandro.

Reply to: