[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Can not get fan control going in wheezy. Any help appreciated


I have solved the problem. At least on my laptop in the last week.

As far as I can tell for that particular model of HP laptop has no way for the user to be able to control the fan.

When I tried to be able to control the fan under windows Vista I downloaded the speedfan utility and it couldn't detect any drivers to control the fan either but did provide a quick way see graphs of the various temperature sensors in the laptop. After that I downloaded a cpu burn test utility for windows and when run it started to heat up the laptop suddenly the fan started up.

Booting back to debian I installed a CPU burn test utility from the repositories. I can't remember the name, I don't have the laptop with me at the moment. When I ran that tool twice in parallel (one for each core) the fan also spontaneously started running.

Now the fan runs fine. It generally runs all the time at a low speed with Debian starts up. I haven't done anything excessive to push it faster since running the burn tests.

The theory I have come to about what is happening is that the fan can not be user controlled and runs automatically. I think maybe it was stuck with dirt and wouldn't run at low speeds. When stressed with the burn test utilities the fan, given more power started up and cleared out any dirt.

Not exactly a scientific theory but the best I can come up that explains the behaviour.

If you happen to run the same tests let me know if you have the same results.

I have reported the problem as a bug to the lm-sensors package:


This weekend I will post a note with my theory and probably another post to debian-users to see if anyone can confirm that it is viable idea.



On Thu, Nov 29, 2012 at 2:08 PM, Tim Long <timwarm@gmail.com> wrote:
Hi all,

I have just updated my laptop (HP Compaq 6730s)  to Wheezy and I am
diagnosing my first problem. The fan control deamon refuses to run and
I think lm-sensors is unable to find/configure the fan control system.
I suspect it a bug with the lm-sensors package.

After the install I get the following message on boot up:
[warn] Not starting fancontrol; run pwmconfig first. ... (warning).

Running pwmconfig I get the following error message:
/usr/sbin/pwmconfig: There are no pwm-capable sensor modules installed

Running the 'sensors' command I turn up the following:
Adapter: Virtual device
temp1:        +53.0°C  (crit = +110.0°C)
temp2:        +49.0°C  (crit = +256.0°C)
temp3:        +49.0°C  (crit = +112.0°C)
temp4:        +51.0°C  (crit = +105.0°C)
temp5:        +30.6°C  (crit = +112.0°C)
temp6:        +50.0°C  (crit = +110.0°C)

Adapter: ISA adapter
Core 0:       +45.0°C  (high = +105.0°C, crit = +105.0°C)
Core 1:       +49.0°C  (high = +105.0°C, crit = +105.0°C)


Googling around for the problem I think the problem is that the
sensors command is not listing any fan control devices. Can anyone
confirm that this is the problem?

 I did run sensor-detect to find any chipset specific modules and it
added 'coretemp' to /etc/modules but I think detected no chipset
specific modules. What is interesting is that it found an unknown
Super I/O chip:
Some Super I/O chips contain embedded sensors. We have to write to
standard I/O ports to probe them. This is usually safe.
Do you want to scan for Super I/O sensors? (YES/no): y
Probing for Super-I/O at 0x2e/0x2f
Trying family `National Semiconductor/ITE'...               No
Trying family `SMSC'...                                     Yes
Found unknown chip with ID 0x4501
Probing for Super-I/O at 0x4e/0x4f
Trying family `National Semiconductor/ITE'...               No
Trying family `SMSC'...                                     No
Trying family `VIA/Winbond/Nuvoton/Fintek'...               No
Trying family `ITE'...                                      No

I think that the problem is that the kernel can not figure out how to
control the fan. Is this the correct diagnosis or have I done a
misdiagnosis? In my google searches I found references to control
files like /sys/class/hwmon/hwmon0/device/fan1_input which don't exist
on my system.

Any help would be appropriated. I think I need to report a bug with
the lm-sensors package.


Reply to: