[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: /lib/systemd/systemd-hostnamed hang

On 11/26/12, Michael Biebl <biebl@debian.org> wrote:
> On 25.11.2012 16:13, Zenaan Harkness wrote:
>> On 11/25/12, Tom H <tomh0665@gmail.com> wrote:
>>> On Sat, Nov 24, 2012 at 6:27 PM, Zenaan Harkness <zen@freedbms.net>
>>> wrote:
>>>> On 11/25/12, Michael Biebl <biebl@debian.org> wrote:
>>>>> On 24.11.2012 14:40, Tom H wrote:
>>>>>> On Sat, Nov 24, 2012 at 6:02 AM, Zenaan Harkness <zen@freedbms.net>
>>>>>> wrote:
>>>>>>> Any idea how to make use of systemd-hostnamed?
>>>>>>> Eg:
>>>>>>> $ sudo /lib/systemd/systemd-hostnamed
>>>>>>> Warning: nss-myhostname is not installed. Changing the local
>>>>>>> hostname
>>>>>>> might make it unresolveable. Please install nss-myhostname!
>>>>>>> # hang's at this point, apparently indefinitely...
>>>>>> What are you expecting it to do?
>>>>> It doesn't hang. It is a system daemon which just waits sits there and
>>>>> waits for requests (via D-Bus).
>>>>> Nothing unexpected here aside from starting this tool directly.
>>>> $ man systemd-hostnamed
>>>> No manual entry for systemd-hostnamed
>>> The latest version of system has hostnamectl and a man page for
>>> systemd-hostnamed.
>> Sounds good. I'll look out for it.
>>> Even if you weren't using systemd, you would've had the xterm problem
>>> because you removed the standard " ..." line from
>>> "/etc/hosts",
>> False assumption. I reinstalled in a bit of a rush, and networking
>> didn't get set up as part of installation. So that line never got put
>> in by the installer. All I had was the localhost line, to
>> which I just added my proper hostname to solve this 'extended delay'
>> problem.
>> Should I put my proper hostname as a separate line instead?
>>> although I'm not sure how xterm would behave with the
>>> hostname known by the kernel being different from the one on the
>>> "" line.
>> It hangs for 10 to 20s before opening. But only with systemd bootup.
>> Today I suspended my laptop, took it off it's dock, put it back on
>> dock about 3 hrs later and tried to unsuspend, no go - various usb
>> errors spewing. Hard reset, no reboot under systemd (disk checks), try
>> again, no.
>> Back to /sbin/init, success. Try a final time to check systemd bootup
>> - no go on systemd.
>> So I'm now stuck back on /sbin/init. Again.
>> And now, the xterm 'extended pause' does not happen, even if I remove
>> my 'proper' hostname from /etc/hosts (so that I cannot ping my
>> hostname).
>> So, I guess it's time to file a bug, somewhere... in relation to systemd
> I have the impression you are fiddling a lot with your system without
> actually knowing what you are doing and you're breaking a lot while
> doing that.

1) I used debian for 6 years or so.
2) I then used Ubuntu 8.04, briefly trying 10.04 (graphics drivers
never worked on my Dell 700m laptop, I tried over quite some months,
following bug reports and attempting all suggestions) and more briefly
12.04, and
3) came back to Debian (struggling with XFCE) about 3 months ago,
trying to find a sane desktop.
4) Since I'm in all this flux anyway, I thought I might as well try
systemd; it looked to me like a sane long term option, even if it's
early days in Debian.
Yes, I am coming from an old world (by Debian/Ubuntu standards), and
_wanting_ to get some sort of currency and long term stable
environment. I'm sincerely trying very hard to get there, although
with not much success at all at the moment.
I'm debating whether to give up for a year or two on Debian and try
LinuxMint Cinnamon or Mate.

5) My internet is a satellite with 1G per month, and connection
latency of upwards of a second - multiply this out many times, and
things can be rather slow, and
6) I admin a few PCs for a non-profit association, so
7) I run a local debian sid/testing mirror (will maintain wheezy when
it becomes stable), by external USB drive updates when I go to a
friend who has a fast ADSL.

> Please only file a bug report if there is actually a valid bug and not
> just some misconfiguration.

Definitely agree. That's why I'm here :)

When I installed off of the Debian testing DVD I downloaded at my
friends place, all I got was a " localhost lo" entry (perhaps
I added the lo) as mentioned.
After logging in the first time, I assigned my default static net
iface config for my local LAN. Given that our power drops out a few
times a year (I live in a rural area), a static config saves a lot of
frustrations when there's no DHCP-running router with power.

A few days later, I realised my hostname was "localhost". So I edited
/etc/hostname and ran hostname _mynewhostname_. A few hours after
that, I went to open a new xterm, and it took over 10 seconds.

Only in the hindsight of my questions to this list, am I now able to
connect these dots clearly and recognize that my
/etc/network/interfaces was missing any entry for _mynewhostname_.

The X session manager has a hostname lookup delay (it seems to me)
when starting an xterm, but only when running systemd (presumably with
hostnamed), and hostnamed seems to say it wants libnss-something.

Yes most people are suburbanites with fast ADSL and probably running
more "default" installs than I.

In the meantime, I was trying to figure out my xterm startup delay,
and am considering the man pages I read, and why it was I didn't find
the answer as quickly as I "ought" to have and without resort to the
mailing list.

If my experience can be useful for improving _something_, even a line
of doco in a man page, then I am willing to go the extra mile to get
to that point, such that something is enhanced for future users.

BTW, I'm up to part XV of the systemd for administrators series, so
still not quite finished with its core doco yet :)


Reply to: