[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: favicon.ico not showing in apache2

On Wed, Nov 14, 2012 at 12:10:15PM +0100, Jorge wrote:
>  Mi web server is apache2 under Debian Squeeze. I've got SSL
> Certificate and user authentication (AuthUser), but I can't manage
> to show the favicon.ico unless I disable both of them.
> Of course, favicon.ico is in the webroot of the VirtualHost and full
> of permissions (just in order to pass the test). I can see the image
> if I go to http://www.ejemplo.com/favicon.ico.
> I've tried (despite I don't like this solution) ...
> <head> <link rel="shortcut icon"
> href=http://www.ejemplo.com/favicon.ico type="image/x-icon" />
> <title>Hello Word Icon</title> </head>
> ... and it works, despite authentication being enabled, by the time
> I go to http://www.ejemplo.com/, but keeps on not showing if I go to
> https://www.ejemplo.com/. And if I put href=https ... instead of
> href=http ... not even that, I can't see any of them.

What do /var/log/apache2/access.log and /var/log/apache2/error.log say
on the matter?

Have you tried a different browser?

Attachment: signature.asc
Description: Digital signature

Reply to: