[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

scid: Location of X11 library: not found

Dear linusers,

Due to license problems, the actual scid package for debian has
disabled the use of tablebase (the menu item is gray).
So, to have this feature, I need to compile it from scratch.

I've followed the steps:

- download the tar.bz2 from the official site
- untar it
- run ./configure

I got some dependency problems with tcl and tk that I already solved.
But there is one that still puzzles me:

# ./configure
configure: Makefile configuration program for Scid
    Renaming "Makefile" to "Makefile.bak"
    Tcl/Tk version: 8.5
    Your operating system is: Linux 3.2.0-4-amd64
    Location of "tcl.h": /usr/include/tcl8.5
    Location of "tk.h": /usr/include/tcl8.5
    Location of Tcl 8.5 library: /usr/lib
    Location of Tk 8.5 library: /usr/lib
    Location of X11 library: not found
    Checking if your system already has zlib installed: yes.
    Using Makefile.conf.
Not all settings could be determined!
The default Makefile was written.
You will need to edit it before you can compile Scid.

I've tried
# apt-get install xlibs xlibs-dev
to no avail.

Also, other tips from ubuntu sites doesn't solve the problem (like xorg-dev).

I wonder, what is the name of the package I need to solve the linking
problem, or if I already have it installed, where is it?
I have no /usr/lib64, although my system is 64bits. And /usr/lib/X11
has only directories rstart  x11perfcomp  xedit  xsm;
I see no libraries there.

I know debian uses xorg now. But how do we compile scid? And how to
create a .deb so we can easily install/uninstall the software after


Dr Beco
A.I. researcher

--> . <--

"Look again at that dot. That's here. That's home. That's us. On it
everyone you love, everyone you know..." (Carl Sagan, 1934-1996)

Reply to: