[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: logrotate: file size changed while zipping

On Thu, 26 Jul 2012 10:42:30 +0200, Slavko wrote:

> in last days (perhaps weeks) i get daily mail from cron's logrotate task
> with this:
> /etc/cron.daily/logrotate:
> gzip: stdin: file size changed while zipping

The error seems coming from "zip.c" library. Have you installed the stock 

Also, have you edited any of the logrotate routines at "/etc/logrotate.d/
*" or have you added a self-made one?

> I was no success to find any solution and i am not able to identify what
> logrotate's job is produced this. I tried to check the logs, but perhaps
> i find bad string - i don't k now. I tried to run logrotate from shell,
> but nothing was written to console.
> Please, can someone help me to identify the source of this message?

If the warning can be reproduced consistently (every day) and you have 
the official packages with no other editions/configurations made by you, 
I would consider in filing a bug report.



Reply to: