[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Unable to install grub in mac mini server

On Sat, Jun 30, 2012 at 7:28 AM, Rodolfo kix Garcia <kix@kix.es> wrote:
> I have a mac mini server (2011). I installed Debian one year ago and all was
> fine. I setup grub without problems, but some days ago the computers was
> rebooted and I cannot boot it. I tried to reinstall grub, but no success.
> This is the configuration:
> 1. Mac mini server has two disks:
>    disk 1 (sda):
>     1: efi partition (original size, 210MB), fat32, "no flags"
>     2: /boot 200mb partition, ext2, "bios_grub flag"
>     3: md0 partition, ~rest of the disk "raid flag"
>    disk 2 (sdb):
>     1: efi partition (original size, 210MB), fat32 "boot flag"
>     2: swap (8GB), "no flags"
>     3: md0 partition, ~rest of the disk, "raid flag"
> Partition tables use GPT.
> 2. I have refit installed. Refit boots and I can select the partitions,...
> 3. Mac OS X is not installed (see disk partitions)
> I can boot with usb drive and rescue disk, select it in refit, boot, mount
> the raid as md0 and chroot it. I can install packages, mount the
> partitions,... Full access.
> I tried a lot of things:
> 1. Reinstall grub2
> 2. Install grub in the EFI and boot it with rEFIt
> 3. Purge grub and reinstall it.
> 4. Grub installed in the partition, in the mbr...
> I got "GRUB loading." and stop. Or "GRUB" and stop.
> Is better use only grub without refit? When I run refit partition table sync
> the partition table changes from GPT to standard MBR and I am not sure if
> that is good.
> Is better use rEFIT?

Which version of grub2 are you installing?

If it isn't "grub-efi-amd64" can you install that and see if works out.

(I have no idea whether it's better to use rEFIT or not)

Reply to: