[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

[solved] Re: Web browser gets slow and blocks the system

On Sun, 27 May 2012 10:28:27 +0000, Rodolfo Medina wrote:

>> Recently I've been having a problem with my web browser: it gets slow,
>> the mouse and the keyboard don't respond any more and I have to unplug
>> the machine. Can anybody suggest how I can detect why this happen and
>> provide a remedy?

Camaleón <noelamac@gmail.com> writes:

>>> How much RAM has your system and what says "free -m" when you launch the
>>> browser?


>> Before launching the browser, the command `free -m' gives something like:
>> $ free -m
>>              total       used       free     shared    buffers   cached 
>> Mem:           216        154         62          0          6      61 
>> -/+ buffers/cache:         85        130 
>> Swap:            0          0          0


> Wow... 216 MB of ram and you have _no swap_? That's suicide...


> When I parted the hard disk, I remeber leaving about 1 gigabite swap,
> and in fact here it is from `parted':
> # parted
> Number  Start   End     Size    Type      File system  Flags
>  1      32.3kB  8390MB  8390MB  primary   fat32        boot 
>  2      8390MB  40.1GB  31.7GB  extended               lba 
>  5      8390MB  9434MB  1045MB  logical   linux-swap 
>  6      9434MB  21.0GB  11.5GB  logical   ext3 
>  7      21.0GB  26.2GB  5239MB  logical   ext3 
>  8      26.2GB  40.1GB  13.8GB  logical   ext3
> I don't know why it does not figure in `free -m', but it is there.

Camaleón <noelamac@gmail.com> writes:

>>> The "/swap" partition has to be mounted. Put here the content of your
>>> "/etc/ fstab".


> (...)
>> # /dev/hda5       					none            	swap    	sw              	0       0 
>> UUID=bdc14217-c199-40fc-ae6b-47657e54cee3       	none           		swap    	sw              	0       0 

Camaleón <noelamac@gmail.com> writes:

> Well, there are two partitions there, the first is commented out (thus 
> not used) and the second seems to be enabled. Check if that UUID 
> corresponds to the swap partition ("ls -la /dev/disk/by-uuid").


>> Maybe the main cause of the problem is the swap partition not mounted?

Camaleón <noelamac@gmail.com> writes:

> Having swap can help but in your case, with as little as 216 MB of RAM
> I don't know if that would be enough.

Well, the cause of the problem seems to be just the absence of the swap.  In
fact, following Camaleón's suggestions, I ran `ls -la /dev/disk/by-uuid' and
noticed that the swap's uuid was different from the one in /etc/fstab.  So I
edited /etc/fstab and put the right uuid, then rebooted and... the problem
disappeared!  I've been testing now for a few days and and it never happened
any more.  I don't know and can't imagine why in /etc/fstab there was a wrong
uuid.  The same problem I had in my netbook and fixed it now.  Now I have the
following output for `free -m':

$ free -m
             total       used       free     shared    buffers     cached
Mem:           216        135         81          0          4         57
-/+ buffers/cache:         74        142
Swap:          996         16        980

without mozilla and, while running mozilla:

$ free -m
             total       used       free     shared    buffers     cached
Mem:           216        209          7          0          5         67
-/+ buffers/cache:        136         80
Swap:          996         17        978

Many thanks to all who replied, and in particular to Camaleón.

Reply to: