[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: dist-upgrades on sid (was: X server: connection refused SOLVED)

On Mon, 07 May 2012 20:50:01 +0200
Andrei POPESCU <andreimpopescu@gmail.com> wrote:

> On Du, 06 mai 12, 22:23:56, Charles Kroeger wrote:
> > 
> > anyway, I couldn't get the X back up until I created that /etc/X11/xorg.conf
> > file again. (a very simple one) but after that, all was once again well.
> If you want any help with this please attach the full 
> /var/log/Xorg.0.log when you try to start without any xorg.conf and the 
> xorg.conf you have now.
> > What do you think happened? I like to think it's sid/experimental walk on the
wild > > side Debian experience, invigorating if it doesn't go on too long.
> I can't give you a better answer than the one from Cyril Brulebois.
> Kind regards,
> Andrei

humm..well yes I appreciate what you say and I did read the links in the Cyril
Brulebois post. (X11 and xorg in transition) I examined ..../log/Xorg.0. after the
first failure of the 'startx' command (to bring up nvidia-glx)  there was some
interesting attempts of X trying to load non-existent 'modules' like 'nv' 'nouveau'
'vesa' etc. Since this log gets recreated each time one runs startx, I put back
some missing packages (removed by the dist-upgrade) then ran startx again and got a
different set of errors but still no X. This is when (from reading other post on
the list) realized I didn't have an /etc/X11/xorg.conf file, so I recreated it and
my problem was resolved i.e. SOLVED. 

Thanks for your reply

Reply to: