[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: dist-upgrades on sid (was: X server: connection refused SOLVED)

On Sun, 06 May 2012 11:30:02 +0200
Andrei POPESCU <andreimpopescu@gmail.com> wrote:

> If you did fine without one before it should work now as well.

It is curious to be sure. But when I tried to edit the /etc/X11/xorg.conf 'after
the dist-upgrade' when startx failed to start the nvidia driver, guess what vim
declared it was a new file.  I made a special effort to make sure I had typed the
file name correctly.

dist-upgrade removed a lot of packages related to X including xserver-xorg that
contained a file I needed to have /usr/bin/X

After reinstalling xserver-xorg and xorg for good measure, I didn't get
the ..xserverrc: 3 exec:  /usr/bin/X: xinit: giving up  error message

anyway, I couldn't get the X back up until I created that /etc/X11/xorg.conf
file again. (a very simple one) but after that, all was once again well.

What do you think happened? I like to think it's sid/experimental walk on the wild
side Debian experience, invigorating if it doesn't go on too long.


Reply to: