[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: error: invalid arch independent elf magic

On Sun, 15 Apr 2012 23:37:49 -0400, Joey L wrote:

> hi all - i am in big trouble and really need good help.
> Something happened to my raid5 array on an ibm x3650 with raid-8k
> controller. I am running debian squeeze with grub --- nothing fancy -
> all my files are on the root filesystem.
> The array was not being recognized by the bios. 

This is a hardware based RAID, right? How is that it was suddenly 
"unrecognized"? Or you mean it was degraded or being rebuilt? :-? 

> So i tried to do a revive - the raid array was rivived and came up with
> a status of okay.

How did you manage to do that? Rescanning from the BIOS of the RAID card?

> I have the grub loader booting now but get the following error:
> error: invalid arch independent elf magic
> I tried googling it...I am very nervous about what I found to get me out
> of this mess.
> So i wanted to ask anyone out there --- how do i get out of it..please
> help.

Some questions first:

- GRUB version (2 or legacy)
- Additional OSes / dual booting?

What I'd would try is booting the system by another mean (from a LiveCD, 
using SuperGrubDisk...). If you can boot normally, it can be that the 
bootloader has been damaged somehow so I would try to reinstall it.



Reply to: