[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: installing source over package



I wanted to post a follow up to my original question.  I believe I now know the consequences.  It broke the package system. I tried to fix it with dpkg -i suggestion.  But, that failed with the

As far as I can tell, make install installed a non LSB cups script into /etc/init.d/.  The next time I tried to run apt-get dist-upgrade, I received a lot of errors:
<snippage>
Reading package lists...
Building dependency tree...
Reading state information...
The following packages were automatically installed and are no longer required:
  libsane-hpaio hplip-data
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  hplip-data libhpmud0 libsane-hpaio printer-driver-hpijs
Suggested packages:
  hpijs-ppds hplip-doc
The following packages will be REMOVED:
  cups* cups-driver-gutenprint* hplip* printer-driver-gutenprint*
  printer-driver-hpcups*
The following packages will be upgraded:
  hplip-data libhpmud0 libsane-hpaio printer-driver-hpijs
4 upgraded, 0 newly installed, 5 to remove and 649 not upgraded.
211 not fully installed or removed.
Need to get 0 B/7,640 kB of archives.
After this operation, 7,660 kB disk space will be freed.
Do you want to continue [Y/n]? Setting up initscripts (2.88dsf-22.1) ...
insserv: warning: script 'K36cups' missing LSB tags and overrides
insserv: warning: script 'cups' missing LSB tags and overrides
insserv: There is a loop at service minissdpd if started
insserv: Starting cups depends on minissdpd and therefore on system facility `$all' which can not be
 true!
</snippage>

The way that I fixed it was by copying a working copy of the cups script from a Debian VM that I have running.  apt-get worked fine after that.  And after upgrading, printing even works.  So, I guess whatever bug existed in cups-filters is fixed in the current version.


On Fri, Apr 6, 2012 at 2:28 PM, Brian <ad44@cityscape.co.uk> wrote:
On Fri 06 Apr 2012 at 14:08:25 -0500, Darren Crotchett wrote:

> I had an issue with the cups-filters package on Wheezy.  I found that the
> bug was resolved in the unstable branch.  But, I wasn't sure how to get the
> unstable branch version of cups.  So, I compiled cups-filters from source
> and installed it on top of my current version (did not uninstall the
> package version first).  This fixed my problem.  But, now I'm wondering
> what the consequences will be and if there was a better way to handle it.

You made it hard for yourself. It would have been sufficient to have
downloaded cups-filters from unstable and installed it with 'dpkg -i'.
You could still do this after purging the cups-filters you have.

> My reasoning for leaving the apt pkg installed was because I wanted apt to
> still upgrade when a new version comes out.

The version you install with 'dpkg -i' will still be upgraded if there
is a higher version available.


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 20120406192856.GF16316@desktop" target="_blank">http://lists.debian.org/20120406192856.GF16316@desktop



Reply to: