[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: difficult to isolate problem - browser access to router has problems on on machine but not other

On Sun, 15 Apr 2012 13:30:14 +0930, Arthur Marsh wrote:

> Hi, I've tried to run through all I can think of and am getting a bit
> stuck.
> I have two machines running Debian (one a dual-core Pentium4 with i386,
> the other a quad-core AMD64-X2 with amd64), both with built-in ethernet
> cards.
> The Pentium4 machine can access the browser interface of the adsl router
> I use with no problems.
> The AMD64 machine has recently taken to stalling after entering the
> username and password for the adsl router's browser interface, and I've
> tried downgrading recent package upgrades, and different kernels and
> browsers without success.

Are you accessing to the router web interface using the same browser from 
both machines? What's the browser that gets stuck after the login screen?

> However, the AMD64 machine booted with the sysrescuecd can access the
> browser interface of the adsl router without problems.

So one problem less: no hardware error on the amd64 computer.
> The AMD64 machine has a built-in Realtek 8169 NIC.
> debsums has so far been inconclusive at pointing to any corrupted files.
> I've also swapped ports that the pc's use on the router without any
> noticeable change, and have powered-down both the pc and router
> completely to eliminate issues caused by power glitches.
> Are there any browsers on Debian that support javascript without having
> to run under the X window system?

Firefox/Iceweasel require an X server to be installed (not in full, just 
the minimal package) but not necessarily a running DE.

> Any other suggestions welcome.

Well, you can check if the router provides a telnet/ssh access 
alternative and manage it from there. I find CLI modes of these devices 
are most stable and reliable than their web interface.



Reply to: