[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: upgrade to Wheezy fails with aptitude

On 21/03/2012 11:01, Pierre Frenkiel wrote:
I wanted to upgrade from Squeeze to Wheezy, and as I saw in several places
that aptitude should be preferred to apt-get, I first tried with it.
I started with only 1 line in sources.list:
deb http://ftp.fr.debian.org/debian/ wheezy main contrib non-free
and tried several times "aptitude safe-upgrade"
Each time, aptitude stayed indefinitely on "resolving dependencies" and did
nothing else.
I then issued: "apt-get dist-upgrade", and all worked perfectly, in less
than 30 minutes.

My question: is it better to also revert to apt-get for package management,
or is the problem specific to the upgrade to a new release?


Did you upgrade aptitude first?

	aptitude install aptitude

This might solve many problems.

I also found aptitude lost in resolve madness while I had too many
foreign packages.  Check the list of manually installed packages

  aptitude search ~i\!~M -F "%p"

to see if you have some of them not provided by the repo pointed in
your one-line sources.list.  Play with =apt-cache policy= to see if
update are available for such foreign-suspected packages.


Reply to: