[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: how to increase space for tmpfs /tmp

On 20120402_165955, Roger Leigh wrote:
> On Mon, Apr 02, 2012 at 08:50:25AM -0600, Paul E Condon wrote:
> > On 20120402_143034, Roger Leigh wrote:
> > > Other than defaulting to mounting a tmpfs on /tmp, there have been
> > > *no other changes*!!  I tend to suspect from this thread that the
> > > problems you are experiencing are entirely self-inflicted, because
> > > they make no logical sense--there's no requirement for a /tmp
> > > entry, and no suggestion of one, and the TMPDIR stuff does not
> > > square with reality.
> > 
> > The possibility that I am hallucinating has occurred to me.  I don't
> > know what I can do to clear my mind. I continue to see my vision. If
> > what I see is real, others will find it. If real, perhaps it is
> > hardware dependent. I don't know. I do know that I have nothing
> > further to give to this discussion. Please accept my inadequacy and
> > move on. I, of course, with have to learn to live with it, but I will
> > try very had to be quiet about it in public, and try to speak of it
> > only to my psychiatrist.
> Er, what?!  There's no need to "learn to live" with any problems.
> And as for the comments about hallucinations and psychiatrists,
> they add zero value to this discussion.  Please just keep it to the
> facts.  If you want help, provide the information so that we can
> help you, otherwise it's entirely worthless--no one, not you, not me
> and not anyone on this list is gaining anything from it.
> If there are problems, clearly state what they are, and I will do
> my best to help.  But so far, you've provided no useful information
> whatsoever, making it impossible to help you.  The comments you
> have made do not make sense.  They are certainly not true for any
> of the systems I've seen unless you've manually changed the init
> scripts to behave the way you've described.
> Regards,
> Roger

I made my system work to my liking by *putting*/tmp*into*/etc/fstab*.
It had never been there before, and it was your private message that
prompted me to think of doing that. I wanted to see what malfunction
you were thinking about when the line was there in order to better
communicate about the problem, but it made the system work, not fail
in a different way. I cannot understand how or why this worked, but
the system once worked flawlessly without the line in /etc/fstab, and
now works flawlessly with the line. (In this context, fail means that
sort aborted with an error message saying that it had run out of
scratch space. When it does that, it also takes care to release
all the space that it might have accumulated during the failed run,
ie. it fails gracefully.)

During my tests, I noticed that there was always a line in df,
concerning /tmp in tmpfs. With RAMTMP=yes the line was labeled tmpfs,
but with RAMTMP=no, the line was labeled 'overflow', or something else
that I misremember as overflow. Now I surmise that tmpfs is being used
during boot whatever the setting of RAMTMP, and is not being shut down
correctly towards the end of the boot process after the loader is
capable of reading /etc/defaults/rcS.  Of course, it can't be as
simple as that, and of course, I can't really understand, but that's
the best I can come up with. There are reasons why I am not a DD.

I now understand that df just reads /proc and displays what it finds
in 'df' format. I could have looked at /proc, I suppose, but at the
time that I was testing I didn't really know where or how 'df' got the
information, and I definitely didn't know where to look in /proc, if I
had thought to verify the 'df' output by checking it against /proc.

If this phenomena cannot be replicated by anyone else then it surely
should not be investigated by anyone in the Debian establishment. The
box is about twelve years old. It was purchased as a grey box from
Frys in California back in the days when the grocery store was still a
active part of the business. I had always found it to be compatible
with Debian, before, but it certainly doesn't seem compatible with
peace in the Debian community, now.

Have I become confused by the not understanding the distinction between
'yes' and 'no'? What other explanation? It flat out doesn't happen the
way you describe.

Suggestions for me to gather information to help work the issue?  
I'll try.  
Would you believe my reports? I am well known as having
hallucinations. It's in the Debian archives.

Paul E Condon 

Reply to: