[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Solved (Re: BADSIG AED4B06F473041FA Debian Archive Automatic Signing Key (6.0/squeeze) <ftpmaster@debian.org>)


It was something weird my university's authenticating proxy was doing.  By changing /etc/apt/apt.conf to proxy differently it worked.  (would this be an old version of a signature on the proxy not being replaced?).

Thanks Tom - I did have the key in my 
apt-key list 


pub   4096R/473041FA 2010-08-27 [expires: 2018-03-05]
uid                  Debian Archive Automatic Signing Key (6.0/squeeze) <ftpmaster@debian.org>

On 23 March 2012 00:41, Tom H <tomh0665@gmail.com> wrote:
lOn Wed, Mar 21, 2012 at 11:32 PM, Robert King
<robert.king@newcastle.edu.au> wrote:
> What am I doing wrong here? I am getting the above error on apt-get update
> solzhenitsyn:~# apt-get update
> Get:1 http://security.debian.org squeeze/updates Release.gpg [836 B]
> Hit http://ftp.au.debian.org squeeze Release.gpg
> Ign http://security.debian.org/ squeeze/updates/contrib Translation-en
> Ign http://security.debian.org/ squeeze/updates/contrib Translation-en_AU
> Ign http://security.debian.org/ squeeze/updates/main Translation-en
> Ign http://security.debian.org/ squeeze/updates/main Translation-en_AU
> Ign http://security.debian.org/ squeeze/updates/non-free Translation-en
> Ign http://security.debian.org/ squeeze/updates/non-free Translation-en_AU
> Get:2 http://security.debian.org squeeze/updates Release [86.9 kB]
> Ign http://security.debian.org squeeze/updates Release
> Ign http://security.debian.org squeeze/updates/main amd64 Packages/DiffIndex
> Ign http://security.debian.org squeeze/updates/contrib amd64
> Packages/DiffIndex
> Ign http://security.debian.org squeeze/updates/non-free amd64
> Packages/DiffIndex
> Hit http://security.debian.org squeeze/updates/main amd64 Packages
> Hit http://security.debian.org squeeze/updates/contrib amd64 Packages
> Hit http://security.debian.org squeeze/updates/non-free amd64 Packages
> Ign http://ftp.au.debian.org/debian/ squeeze/contrib Translation-en
> Ign http://ftp.au.debian.org/debian/ squeeze/contrib Translation-en_AU
> Ign http://ftp.au.debian.org/debian/ squeeze/main Translation-en
> Ign http://ftp.au.debian.org/debian/ squeeze/main Translation-en_AU
> Ign http://ftp.au.debian.org/debian/ squeeze/non-free Translation-en
> Ign http://ftp.au.debian.org/debian/ squeeze/non-free Translation-en_AU
> Hit http://ftp.au.debian.org squeeze Release
> Hit http://ftp.au.debian.org squeeze/main amd64 Packages
> Hit http://ftp.au.debian.org squeeze/contrib amd64 Packages
> Hit http://ftp.au.debian.org squeeze/non-free amd64 Packages
> Fetched 837 B in 2s (336 B/s)
> Reading package lists... Done
> W: GPG error: http://security.debian.org squeeze/updates Release: The
> following signatures were invalid: BADSIG AED4B06F473041FA Debian Archive
> Automatic Signing Key (6.0/squeeze) <ftpmaster@debian.org>
> this is on the basis of the following
> solzhenitsyn:~# more /etc/apt/sources.list
> deb http://ftp.au.debian.org/debian/ squeeze main contrib non-free
> deb http://security.debian.org/ squeeze/updates main contrib non-free
> If I check my keyring, I think have the correct key:
> solzhenitsyn:~# gpg --list-keys
> /root/.gnupg/pubring.gpg
> ------------------------
> pub   1024D/16BA136C 2005-08-21
> uid                  Backports.org Archive Key <ftp-master@backports.org>
> sub   2048g/5B82CECE 2005-08-21
> pub   1024D/381BA480 2007-02-15
> uid                  Johannes Ranke (CRAN Debian archive)
> <jranke@uni-bremen.de>
> pub   2048R/E084DAB9 2010-10-19 [expires: 2015-10-18]
> uid                  Michael Rutter <marutter@gmail.com>
> sub   2048R/1CFF3E8F 2010-10-19 [expires: 2015-10-18]
> pub   4096R/473041FA 2010-08-27 [expires: 2018-03-05]
> uid                  Debian Archive Automatic Signing Key (6.0/squeeze)
> <ftpmaster@debian.org>
> searching on this error had suggestions to try:
> # apt-key adv --keyserver keyserver.debian.org --recv-keys AED4B06F473041FA
> Executing: gpg --ignore-time-conflict --no-options --no-default-keyring
> --secret-keyring /etc/apt/secring.gpg --trustdb-name /etc/apt/trustdb.gpg
> --keyring /etc/apt/trusted.gpg --primary-keyring /etc/apt/trusted.gpg
> --keyserver keyserver.debian.org --recv-keys AED4B06F473041FA
> gpg: requesting key 473041FA from hkp server keyserver.debian.org
> gpgkeys: HTTP fetch error 6: Couldn't resolve host 'keyserver.debian.org'
> gpg: no valid OpenPGP data found.
> gpg: Total number processed: 0
> I do have debian-keyring installed.

What's does "apt-key list" give you. I get the following on a wheezy
box upgraded to sid.

# apt-key list
pub   1024D/F42584E6 2008-04-06 [expires: 2012-05-15]
uid                  Lenny Stable Release Key <debian-release@lists.debian.org>

pub   4096R/55BE302B 2009-01-27 [expires: 2012-12-31]
uid                  Debian Archive Automatic Signing Key (5.0/lenny)

pub   2048R/6D849617 2009-01-24 [expires: 2013-01-23]
uid                  Debian-Volatile Archive Automatic Signing Key (5.0/lenny)

pub   4096R/B98321F9 2010-08-07 [expires: 2017-08-05]
uid                  Squeeze Stable Release Key

pub   4096R/473041FA 2010-08-27 [expires: 2018-03-05]
uid                  Debian Archive Automatic Signing Key
(6.0/squeeze) <ftpmaster@debian.org>

To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: http://lists.debian.org/CAOdoSyj737G9i1thEXijcRKUdh3xYAYakCciSNW5HN-9ed-w@mail.gmail.com

Reply to: