[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

debtags shows error

Hello list,

I am getting a strange errror, and I believe, the reason might be caused by 
the debian server.

Running "aptitude update" is showing me;:

gn ftp://ftp.de.debian.org stable/non-free Translation-de
Hole: 55 ftp://ftp.de.debian.org stable/non-free Translation-en
Ign ftp://ftp.de.debian.org stable/non-free Translation-en
W: Der debtags-Aktualisierungsprozess (/usr/bin/debtags update --local) wurde 
mit einem Fehler beendet (Code 1).

I ran "strace debtags update --local" and this showed me the following:

futex(0x7fa4ff8323c4, FUTEX_WAKE_PRIVATE, 2147483647) = 0
close(5)                                = 0
munmap(0x7fa500b5c000, 4096)            = 0
close(4)                                = 0
unlink("/var/lib/debtags/package-tags.QrRMvq") = 0
close(3)                                = 0
munmap(0x7fa500b5d000, 4096)            = 0
write(2, "separator character ends the lin"..., 63separator character ends the 
line. Context:
    Parsing line 48) = 63
write(2, "\n", 1
)                       = 1
exit_group(1)                           = ?

I examined package-tags, but could not see something weird, so I moved it 
away, and let it new create - with the same result. IMO the reason is in the 
debian server. BTW, in the past I got often lots of warnings, as some packages 
(like cnews) got wrong syntax for its version.

Maybe you could take a look at it?

Best regards


Reply to: